UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor phjonesisu
Visitor
12,083 Views
Registered: ‎12-10-2008

No filesystem could mount root, when booting Xilinx open source Linux on ML507

Jump to solution

I am a new professor at Iowa State University (Ames, IA).  And am looking to integrate the Xilinx open source Linux, and the ML507 into my classes, and research.

 

 

I’ve been going through the GREAT directions that have been provided at: http://xilinx.wikidot.com/configuring-building-and-loading-linux-after-9-1-08  and believe I am very close to getting the Xilinx open source Linux to fully boot.  However it crashes with the following message:

 

No filesystem could mount root, tried:  ext2 cramfs vfat msdos romfs

Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(1,0)

Rebooting in 180 seconds..

 

 

It looks like the initrd image, which has the ramdisk in the kernel image, is not being loaded.  Which is named:

 

simpleImage.initrd.virtex440-ml507

 

 

 However I do not see how one goes about loading the initrd image. 

 

 

        I ran the following commands:

 

make ARCH=powerpc 44x/virtex5_defconfig

make ARCH=powerpc zImage

XMD% connect ppc hw -debugdevice deviceNr 5 cpunr 1
XMD% dow arch/powerpc/boot/simpleImage.virtex440-ml507.elf
XMD% run

 

I did make a small change to my virtex440-ml507.dts file to give the OS a static IP

 

Changed from: bootargs = "console=ttyS0 ip=on root=/dev/ram";

                   to:       bootargs = "console=ttyS0 ip=192.168.1.10 root=/dev/ram";

 

I have attached my .dts file.

 

 

Here is the output from minicom when the OS tries to boot:

 

Linux/PowerPC load: console=ttyS0 ip=192.168.1.10 root=/dev/ram

Finalizing device tree... flat tree at 0x5a3300

Using Xilinx Virtex440 machine description

Linux version 2.6.28-rc6 (phjones@xilinx.ece.iastate.edu) (gcc version 4.0.0 (D8

Zone PFN ranges:

  DMA      0x00000000 -> 0x00010000

  Normal   0x00010000 -> 0x00010000

Movable zone start PFN for each node

early_node_map[1] active PFN ranges

    0: 0x00000000 -> 0x00010000

Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 65024

Kernel command line: console=ttyS0 ip=192.168.1.10 root=/dev/ram

Xilinx intc at 0x81800000 mapped to 0xfdfff000

PID hash table entries: 1024 (order: 10, 4096 bytes)

clocksource: timebase mult[a00000] shift[22] registered

Console: colour dummy device 80x25

Dentry cache hash table entries: 32768 (order: 5, 131072 bytes)

Inode-cache hash table entries: 16384 (order: 4, 65536 bytes)

Memory: 256128k/262144k available (3172k kernel code, 5776k reserved, 136k data)

Calibrating delay loop... 798.72 BogoMIPS (lpj=1597440)

Mount-cache hash table entries: 512

net_namespace: 636 bytes

NET: Registered protocol family 16

PCI: Probing PCI hardware

NET: Registered protocol family 2

IP route cache hash table entries: 2048 (order: 1, 8192 bytes)

TCP established hash table entries: 8192 (order: 4, 65536 bytes)

TCP bind hash table entries: 8192 (order: 3, 32768 bytes)

TCP: Hash tables configured (established 8192 bind 8192)

TCP reno registered

NET: Registered protocol family 1

Installing knfsd (copyright (C) 1996 okir@monad.swb.de).

msgmni has been set to 500

io scheduler noop registered

io scheduler anticipatory registered

io scheduler deadline registered

io scheduler cfq registered (default)

Serial: 8250/16550 driver4 ports, IRQ sharing disabled

83e00000.serial: ttyS0 at MMIO 0x83e01003 (irq = 16) is a 16550A

console [ttyS0] enabled

brd: module loaded

loop: module loaded

Device Tree Probing 'ethernet'

xilinx_lltemac 81c00000.ethernet: MAC address is now  2: 0: 0: 0: 0: 0

xilinx_lltemac 81c00000.ethernet: XLlTemac: using DMA mode.

XLlTemac: DCR address: 0x80                                     

XLlTemac: buffer descriptor size: 32768 (0x8000)

XLlTemac: Allocating DMA descriptors with kmalloc<6>XLlTemac: (buffer_descripto0

XTemac: PHY detected at address 7.

xilinx_lltemac 81c00000.ethernet: eth0: Xilinx TEMAC at 0x81C00000 mapped to 0x7

mice: PS/2 mouse device common for all mice

i2c /dev entries driver

TCP cubic registered

NET: Registered protocol family 17

RPC: Registered udp transport module.

RPC: Registered tcp transport module.

eth0: XLlTemac: Options: 0x3fa

eth0: XLlTemac: allocating interrupt 19 for dma mode tx.

eth0: XLlTemac: allocating interrupt 18 for dma mode rx.

eth0: XLlTemac: speed set to 1000Mb/s

eth0: XLlTemac: Send Threshold = 24, Receive Threshold = 4

eth0: XLlTemac: Send Wait bound = 254, Receive Wait bound = 254

IP-Config: Guessing netmask 255.255.255.0

IP-Config: Complete:

     device=eth0, addr=192.168.1.10, mask=255.255.255.0, gw=255.255.255.255,

     host=192.168.1.10, domain=, nis-domain=(none),

     bootserver=255.255.255.255, rootserver=255.255.255.255, rootpath=

List of all partitions:

No filesystem could mount root, tried:  ext2 cramfs vfat msdos romfs

Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(1,0)

Rebooting in 180 seconds..

 

 

Thank you for any suggestions you have.

 

Phillip.

0 Kudos
1 Solution

Accepted Solutions
Visitor phjonesisu
Visitor
13,667 Views
Registered: ‎12-10-2008

Re: No filesystem could mount root, when booting Xilinx open source Linux on ML507

Jump to solution

Issue fixed.

 

The wiki page has been updated to give more detials on using a ramdisk.

 

http://xilinx.wikidot.com/configuring-building-and-loading-linux-after-9-1-08

 

 

 The fundumental issue I was having was that I was not placing "ramdisk.image.gz" in the arch/powerpc/boot directory.  And I did not realize you have to download this file from:

 

http://xilinx.wikidot.com  (click on "file" at the bottom of the page to make the file downlaod options appear)

 

 

 I would also think their should be a way to make your own "ramdisk.image.gz"??

 

 

 Note: if you are using a ramdisk (i.e. kernel commnad line has "root=/dev/ram"), then

 

Instead of running:  XMD% dow arch/powerpc/boot/simpleImage.virtex440-ml507.elf, as shown on the wiki page

 

run:  XMD% dow arch/powerpc/boot/simpleImage.initrd.virtex440-ml507.elf

 

 

Thanks for updating the wiki page!

 

 

Phillip.

View solution in original post

0 Kudos
4 Replies
Xilinx Employee
Xilinx Employee
12,081 Views
Registered: ‎09-10-2008

Re: No filesystem could mount root, when booting Xilinx open source Linux on ML507

Jump to solution

Hi Phillip,

 

It looks like you’re not loading the initrd image which has the ramdisk in the kernel image.

 

simpleImage.initrd.virtex440-ml507

 

You need to load this image to use the ram disk.

 

I updated the wiki with a ramdisk section which should better answer this question.

 

-- John

 

 

Visitor phjonesisu
Visitor
13,668 Views
Registered: ‎12-10-2008

Re: No filesystem could mount root, when booting Xilinx open source Linux on ML507

Jump to solution

Issue fixed.

 

The wiki page has been updated to give more detials on using a ramdisk.

 

http://xilinx.wikidot.com/configuring-building-and-loading-linux-after-9-1-08

 

 

 The fundumental issue I was having was that I was not placing "ramdisk.image.gz" in the arch/powerpc/boot directory.  And I did not realize you have to download this file from:

 

http://xilinx.wikidot.com  (click on "file" at the bottom of the page to make the file downlaod options appear)

 

 

 I would also think their should be a way to make your own "ramdisk.image.gz"??

 

 

 Note: if you are using a ramdisk (i.e. kernel commnad line has "root=/dev/ram"), then

 

Instead of running:  XMD% dow arch/powerpc/boot/simpleImage.virtex440-ml507.elf, as shown on the wiki page

 

run:  XMD% dow arch/powerpc/boot/simpleImage.initrd.virtex440-ml507.elf

 

 

Thanks for updating the wiki page!

 

 

Phillip.

View solution in original post

0 Kudos
Visitor tomams
Visitor
8,867 Views
Registered: ‎11-02-2008

Re: No filesystem could mount root, when booting Xilinx open source Linux on ML507

Jump to solution

to mount nfs

 

bootargs:  root=/dev/nfs rw ip=on

 

tom

0 Kudos
Anonymous
Not applicable
8,862 Views

Re: No filesystem could mount root, when booting Xilinx open source Linux on ML507

Jump to solution

Take a look at this post for modifying the ramdisk image:

 

http://forums.xilinx.com/xlnx/board/message?board.id=ELINUX&message.id=1089#M1089

 

Terry

 

0 Kudos