UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Contributor
Contributor
748 Views
Registered: ‎11-09-2007

Passing FSBL results to u-boot on Petalinux 2017.4

Jump to solution

OK, so on Petalinux 2017.4 I had a modified fsbl which looked at dip switches on a zc706 board to set the low bits of the Ethernet MAC address. This was then passed from the FSBL to U-Boot using the on-chip RAM and storing a configuration message at address 0xfffffc00. With 2017.4 this no longer seems to work. 

 

I think my FSBL is working because I can see the correct message in the RAM from the u-boot command line using the md command. But if I do a printenv macaddr I still see the default MAC address.

 

Has this magic address changed for 2017.4? Is there a symbol that I can use rather than the physical address? Or is there a completely different mechanism?

 

Thanks,

 

-Pete

 

0 Kudos
1 Solution

Accepted Solutions
Contributor
Contributor
813 Views
Registered: ‎11-09-2007

Re: Passing FSBL results to u-boot on Petalinux 2017.4

Jump to solution

I write the string ethaddr=00:0a:35:00:00:0f to address 0xfffffc00.

 

But your question got me to wondering how I knew to do that. Which led me to this post https://forums.xilinx.com/t5/Embedded-Linux/MAC-address-EEPROM-Petalinux/td-p/668780. It is clear from here that I had forgotten about the other half of this which is that platform-top.h in the u-boot config headers needs to be modifier to read this location and import the string written there.

#undef CONFIG_PREBOOT
#define CONFIG_PREBOOT	"echo U-BOOT for ${hostname};setenv preboot; echo;env import -t 0xFFFFFC00;dhcp"

So I think that solves the problem. Now the next issue I have is patching the FSBL and getting that to build which is in another post. Now I have to figure out how to patch u-boot as well.

 

Thanks though. At least I think I have this question answered now.

0 Kudos
2 Replies
Moderator
Moderator
700 Views
Registered: ‎09-12-2007

Re: Passing FSBL results to u-boot on Petalinux 2017.4

Jump to solution

How are you saving the MAC addr, as I dont think the saveenv is enabled by default in the uboot config

0 Kudos
Contributor
Contributor
814 Views
Registered: ‎11-09-2007

Re: Passing FSBL results to u-boot on Petalinux 2017.4

Jump to solution

I write the string ethaddr=00:0a:35:00:00:0f to address 0xfffffc00.

 

But your question got me to wondering how I knew to do that. Which led me to this post https://forums.xilinx.com/t5/Embedded-Linux/MAC-address-EEPROM-Petalinux/td-p/668780. It is clear from here that I had forgotten about the other half of this which is that platform-top.h in the u-boot config headers needs to be modifier to read this location and import the string written there.

#undef CONFIG_PREBOOT
#define CONFIG_PREBOOT	"echo U-BOOT for ${hostname};setenv preboot; echo;env import -t 0xFFFFFC00;dhcp"

So I think that solves the problem. Now the next issue I have is patching the FSBL and getting that to build which is in another post. Now I have to figure out how to patch u-boot as well.

 

Thanks though. At least I think I have this question answered now.

0 Kudos