cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
18,552 Views
Registered: ‎03-13-2012

PetaLinux 20115.2 installer fails

Jump to solution

Hi all,

 

I'm running Ubuntu 14.04 with openssl installed. I do the standard petalinux 2015.2 tool installation as sudo, get through the license agreements (just like in 2014.4), and then get this error:

 

 

Press Enter to display the license agreements
Do you accept Xilinx End User License Agreement? [y/N] > y
Do you accept Webtalk Terms and Conditions? [y/N] > y
Do you accept Third Party End User License Agreement? [y/N] > y
INFO: Checking installation environment requirements...
INFO: Checking free disk space
INFO: Checking installed tools
INFO: Checking installed development libraries
ERROR: You are missing these development libraries required by PetaLinux:

 - openssl

Please install them with your operating system package manager, and try again

However, openssl is installed and updated. What's going on? Has anyone run into this?

0 Kudos
1 Solution

Accepted Solutions
danwwright
Contributor
Contributor
31,212 Views
Registered: ‎10-12-2014

Yes "sudo apt-get install libssl-dev" on Ubuntu fixed thde issue.  Thanks!

 

View solution in original post

11 Replies
danwwright
Contributor
Contributor
18,482 Views
Registered: ‎10-12-2014

I have the exact same issue.  Ubuntu 14.04 with openssl installed.  But I still get the exact same error about a missing

openssl.

0 Kudos
danwwright
Contributor
Contributor
18,473 Views
Registered: ‎10-12-2014

dwright@dwright-Studio-XPS-9100:~/Downloads$ sudo ./petalinux-v2015.2-final-installer.run /opt/INFO: Checking installer checksum...
INFO: Extracting PetaLinux installer...
INFO: Installing PetaLinux...
INFO: Checking PetaLinux installer integrity...
INFO: Extracting Installation files...

LICENSE AGREEMENTS

PetaLinux SDK contains software from a number of sources.  Please review
the following licenses and indicate your acceptance of each to continue.

You do not have to accept the licenses, however if you do not then you may
not use PetaLinux SDK.

Use PgUp/PgDn to navigate the license viewer, and press 'q' to close

Press Enter to display the license agreements
Do you accept Xilinx End User License Agreement? [y/N] > y
Do you accept Webtalk Terms and Conditions? [y/N] > y
Do you accept Third Party End User License Agreement? [y/N] > y
INFO: Checking installation environment requirements...
INFO: Checking free disk space
INFO: Checking installed tools
INFO: Checking installed development libraries
ERROR: You are missing these development libraries required by PetaLinux:

 - openssl

Please install them with your operating system package manager, and try again
dwright@dwright-Studio-XPS-9100:~/Downloads$

0 Kudos
achutha
Xilinx Employee
Xilinx Employee
18,446 Views
Registered: ‎07-01-2010

@danwwright @vadim_bottomline

 

This error message indicates that you don’t have the required tools or libraries.In this case it is looking for openssl.

 

Can you try the details in the link and see if doing the same fix's the issue?

 

Please let me know if this helps.

 

Regards,

Achutha

---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------
danwwright
Contributor
Contributor
31,213 Views
Registered: ‎10-12-2014

Yes "sudo apt-get install libssl-dev" on Ubuntu fixed thde issue.  Thanks!

 

View solution in original post

vanmierlo
Mentor
Mentor
18,413 Views
Registered: ‎06-10-2008

Indeed, installing openssl-devel did the trick on CentOS.

0 Kudos
achutha
Xilinx Employee
Xilinx Employee
18,408 Views
Registered: ‎07-01-2010

@danwwright @vanmierlo

 

Thanks for trying the details and updating the thread.

 

I will publish an answer record on this.

 

Regards,

Achutha

---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------
0 Kudos
hs2
Visitor
Visitor
18,336 Views
Registered: ‎07-21-2015

@achutha

 

You should add this information to the answer record resp. create a new one.

 

Thanks, HS2

0 Kudos
achutha
Xilinx Employee
Xilinx Employee
18,334 Views
Registered: ‎07-01-2010

@hs2

 

I have created an Answer record and will request to publish it.

 

Regards,

Achutha

---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------
0 Kudos
18,293 Views
Registered: ‎03-13-2012

@achutha

Thanks for the timely answer record, this will help people out. Glad I could report something that affects others...

 

Is there a way to rename the subject of the thread? I had a typo, an extra "1".

0 Kudos
eneserdin
Observer
Observer
5,197 Views
Registered: ‎12-25-2007

Hi,

 

While installing PetaLinux 2016.3 on my Ubuntu 16.04 also I got the ncurses error. Looking at the solutions I installed development package for ncurses. It installed.

 

FYI

0 Kudos
ram14
Visitor
Visitor
3,624 Views
Registered: ‎09-27-2018

try this command

sudo apt-get install libssl-dev

0 Kudos