cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Observer
Observer
3,835 Views
Registered: ‎01-19-2018

PetaLinux 2018.1 build warnings

Jump to solution

Hello,

 

I am migrating my PetaLinux 2017.4 project to 2018.1, and I've gotten it to build and run OK, but I'm seeing warnings during the build that make me worry I'm doing something wrong.  My project targets the microzed_7020 board, which has a Zynq xc7z020clg400-1.  I was getting this warning at first:

 

WARNING: You have included the meta-virtualization layer, but 'virtualization' has not been enabled in your DISTRO_FEATURES. Some bbappend files may not take effect. See the meta-virtualization README for details on enabling virtualization support.

I tried adding the line

 

DISTRO_FEATURES_append = " virtualization"

 

to my project-spec/meta-user/conf/petalinuxbsp.conf file, and that warning went away, but now I'm getting a new warning:

 

WARNING: The glib-2.0:do_install sig is computed to be c125c4e350de0485f194653613180b9f, but the sig is locked to 6e2389ef983fb7268416b71a4806b4f4 in SIGGEN_LOCKEDSIGS_t-cortexa9hf-neon

 

I also get a different warning whether or not I tweak my DISTRO_FEATURES:

 

WARNING: petalinux-user-image-1.0-r0 do_rootfs: [log_check] petalinux-user-image: found 1 warning message in the logfile:
[log_check] warning: %post(sysvinit-inittab-2.88dsf-r10.plnx_zynq7) scriptlet failed, exit status 1

 

Anyone know the right way to deal with these warnings?  Thanks!

 

Asa

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Moderator
Moderator
4,620 Views
Registered: ‎12-04-2016

Hi

 

To overcome the warning on sig gen, try adding below one to project-spec/meta-user/conf/petalinuxbsp.conf

SIGGEN_UNLOCKED_RECIPES += "glib-2.0"

 

And you dont need to worry about the last warning message 

 

 

Best Regards

Shabbir

View solution in original post

3 Replies
Highlighted
Moderator
Moderator
4,621 Views
Registered: ‎12-04-2016

Hi

 

To overcome the warning on sig gen, try adding below one to project-spec/meta-user/conf/petalinuxbsp.conf

SIGGEN_UNLOCKED_RECIPES += "glib-2.0"

 

And you dont need to worry about the last warning message 

 

 

Best Regards

Shabbir

View solution in original post

Highlighted
Participant
Participant
3,758 Views
Registered: ‎03-10-2015

I'm doing a large upgrade on our systems (2015.4 to 2018.1) and I ran into these exact same warnings.  Thanks for the solution to the glib warning, and it's nice to know the other warning can be ignored.

0 Kudos
Highlighted
Voyager
Voyager
855 Views
Registered: ‎08-02-2019

Thanks @shabbirk , it worked for me also on 2018.2

Saban

<--- If reply is helpful, please feel free to give Kudos, and close if it answers your question --->
0 Kudos