UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor asooy
Visitor
264 Views
Registered: ‎08-05-2018

PetaLinux 2018.2 OP-TEE (bl32) not detected/initializing on ultra96 board (zynq ultrascale+ ZU3EG A484)

Jump to solution

I am deploying this on an ultra96 board using the zynqmp.mk now in the op-tee build repository. 

The bif I am using

rom_image:

{

                [bootloader] zynqmp_fsbl.elf

                [pmufw_image] pmufw.elf

                [destination_device=pl] system.bit

                [destination_cpu=a53-0, exception_level=el-3, trustzone] bl31.elf

                [destination_cpu=a53-0, exception_level=el-2] u-boot.elf

                [destination_cpu=a53-0, exception_level=el-1, trustzone] bl32.elf

}

Linux does boot. The xtest, ta devkit, and the supplicant are present. However, it is not detecting the secure os.

0 Kudos
1 Solution

Accepted Solutions
Visitor asooy
Visitor
209 Views
Registered: ‎08-05-2018

Re: PetaLinux 2018.2 OP-TEE (bl32) not detected/initializing on ultra96 board (zynq ultrascale+ ZU3EG A484)

Jump to solution

I was ableto get everything working in petalinux with the following BIF:

 

the_ROM_image: {

[destination_cpu=a53-0, bootloader] ./images/linux/zynqmp_fsbl.elf
[pmufw_image] ./images/linux/pmufw.elf
[destination_device=pl] ./images/linux/system.bit
[destination_cpu=a53-0, exception_level=el-3, trustzone] ./images/linux/bl31.elf
[destination_cpu=a53-0, exception_level=el-2] ./images/linux/u-boot.elf
[destination_cpu=a53-0, exception_level=el-1, trustzone] ./images/linux/bl32.elf
./images/linux/system.dtb

}

0 Kudos
1 Reply
Visitor asooy
Visitor
210 Views
Registered: ‎08-05-2018

Re: PetaLinux 2018.2 OP-TEE (bl32) not detected/initializing on ultra96 board (zynq ultrascale+ ZU3EG A484)

Jump to solution

I was ableto get everything working in petalinux with the following BIF:

 

the_ROM_image: {

[destination_cpu=a53-0, bootloader] ./images/linux/zynqmp_fsbl.elf
[pmufw_image] ./images/linux/pmufw.elf
[destination_device=pl] ./images/linux/system.bit
[destination_cpu=a53-0, exception_level=el-3, trustzone] ./images/linux/bl31.elf
[destination_cpu=a53-0, exception_level=el-2] ./images/linux/u-boot.elf
[destination_cpu=a53-0, exception_level=el-1, trustzone] ./images/linux/bl32.elf
./images/linux/system.dtb

}

0 Kudos