cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
4,040 Views
Registered: ‎11-02-2016

PetaLinux U-Boot: Phy is not detected

U-Boot 2016.07 (Jan 25 2017 - 14:30:53 +0100) Xilinx ZynqMP ZCU102 revB

DRAM: 2 GiB
EL Level: EL2
Chip ID: xczu9eg
MMC: sdhci@ff160000: 0
SF: Detected N25Q512A with page size 512 Bytes, erase size 128 KiB, total 128 MiB
*** Warning - bad CRC, using default environment

In: serial
Out: serial
Err: serial
Bootmode: QSPI_MODE
Net: ZYNQ GEM: ff0e0000, phyaddr 1, interface gmii
PHY is not detected GEM PHY init failed No ethernet found. U-BOOT for ZYNQ GEM: ff0e0000, phyaddr 1, interface gmii mdio_register: non unique device name 'gem' ZYNQ GEM: ff0e0000, phyaddr 1, interface gmii mdio_register: non unique device name 'gem' ZYNQ GEM: ff0e0000, phyaddr 1, interface gmii mdio_register: non unique device name 'gem' ZYNQ GEM: ff0e0000, phyaddr 1, interface gmii mdio_register: non unique device name 'gem' No ethernet found. ZYNQ GEM: ff0e0000, phyaddr 1, interface gmii mdio_register: non unique device name 'gem'

I get following output from U-Boot, when I create a PetaLinux Project without modification.

 

Any hints where to start for solving this problem?

0 Kudos
4 Replies
Highlighted
Participant
Participant
2,310 Views
Registered: ‎10-27-2017

Re: PetaLinux U-Boot: Phy is not detected

I'm having the same issue on Zync-7000. Did you solve it already? It might help me.
0 Kudos
Highlighted
Moderator
Moderator
2,277 Views
Registered: ‎09-12-2007

Re: PetaLinux U-Boot: Phy is not detected

Are you using the zcu102, or a custom board?
0 Kudos
Highlighted
Participant
Participant
2,219 Views
Registered: ‎10-27-2017

Re: PetaLinux U-Boot: Phy is not detected

I'm using a custom board (based on the zedboard afaik) with the zynq xc7z010. I actually posted a separate question https://forums.xilinx.com/t5/Embedded-Linux/Zynq-7010-u-boot-PHY-is-not-detected/td-p/804993

Even though OP uses a different board, his output is nearly (except for the GEM address) identical to mine.
0 Kudos
Highlighted
Visitor
Visitor
197 Views
Registered: ‎01-02-2020

Re: PetaLinux U-Boot: Phy is not detected

am facing the same problem and am not sure how to go about it . i am using petalinux 2018.3 and zybo board . i created bsp from scratch

0 Kudos