cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Contributor
Contributor
1,294 Views
Registered: ‎04-22-2011

PetaLinux environment build_with_: command not found

Jump to solution

Hi;

I am using PetaLinux 2019.2 and try to creat a Petalinux project.

create a petalinux project, configure the project, and then build the project by runnig "petalinux-build", but I receive the floowing error:

[INFO] building project
[INFO] sourcing bitbake
[INFO] generating user layers
[INFO] generating workspace directory
environment: line 2504: build_with_: command not found
ERROR: Failed to build project

Could you please advise me how to resolve this issue?

I would greatly appreciate if someone answer my query.

Thank you.

 

0 Kudos
Reply
1 Solution

Accepted Solutions
Highlighted
Contributor
Contributor
1,018 Views
Registered: ‎04-22-2011

@satguy well. I worked on this issue for a few days. I couldn't resolve it. Apart from this server, I got several servers in the lab and installed the software on one of them. Now I can see everything is fine and I don't receive this error anymore....

View solution in original post

0 Kudos
Reply
13 Replies
Highlighted
Explorer
Explorer
1,286 Views
Registered: ‎04-19-2018

 

"create a petalinux project, configure the project, and then build the project"

Maybe all the evil is in that configuration you bundle it all behind a word. Could you attach the config file?

0 Kudos
Reply
Highlighted
Explorer
Explorer
1,281 Views
Registered: ‎04-19-2018

 

Bear in mind Petalinux wraps Yocto that is build in Python and whenever there is an error, there is a spew of lines of code (you haven't written), Python file errors (you don't know anything about) and possibly additional random characters, all in red, probably to try to provoke a stroke to the user to minimize the number of complains.

In ancient times, error messages had the purpose of guiding the user to sort them out. now the purpose seem to be to scroll some line to change the overall color.

0 Kudos
Reply
Highlighted
Contributor
Contributor
1,270 Views
Registered: ‎04-22-2011

@satguy Thanks for your message.

I have attached the file. ( I changed it to .txt as it can't be attched if I dont do it)

 

0 Kudos
Reply
Highlighted
Explorer
Explorer
1,248 Views
Registered: ‎04-19-2018

quite a standard config... I'm not sure about this:


CONFIG_SUBSYSTEM_HOSTNAME="zcu102_dpu-ubuntu-petalinux"
CONFIG_SUBSYSTEM_PRODUCT="zcu102_dpu-ubuntu-petalinux"

Are you building ubuntu for Zynq?

0 Kudos
Reply
Highlighted
Contributor
Contributor
1,232 Views
Registered: ‎04-22-2011

@satguy No , I am not at this stage, only the name is 'zcu102_dpu-ubuntu-petalinux'

Here are the commands I used:

hpnroot@hpn118:/opt/workspace/DPU$ petalinux-create -t project --template zynqMP -n zcu102_dpu-ubuntu-petalinux
INFO: Create project: zcu102_dpu-ubuntu-petalinux
INFO: New project successfully created in /opt/workspace/DPU/zcu102_dpu-ubuntu-petalinux
hpnroot@hpn118:/opt/workspace/DPU$ cd zcu102_dpu-ubuntu-petalinux/
hpnroot@hpn118:/opt/workspace/DPU/zcu102_dpu-ubuntu-petalinux$ petalinux-config --get-hw-description=../hardware_files
INFO: Getting hardware description...
INFO: Rename zcu102_dpu.xsa to system.xsa
[INFO] generating Kconfig for project
[INFO] menuconfig project


*** End of the configuration.
*** Execute 'make' to start the build or try 'make help'.

[INFO] sourcing bitbake
[INFO] generating plnxtool conf
[INFO] generating meta-plnx-generated layer
[INFO] generating user layers
[INFO] generating workspace directory
[INFO] generating bbappends for project . This may take time !
[INFO] generating u-boot configuration files
[INFO] generating kernel configuration files
[INFO] generating kconfig for Rootfs
[INFO] silentconfig rootfs
[INFO] generating petalinux-user-image.bb
hpnroot@hpn118:/opt/workspace/DPU/zcu102_dpu-ubuntu-petalinux$ petalinux-build
[INFO] building project
[INFO] sourcing bitbake
[INFO] generating user layers
[INFO] generating workspace directory
environment: line 2504: build_with_: command not found
ERROR: Failed to build project

0 Kudos
Reply
Highlighted
Explorer
Explorer
1,227 Views
Registered: ‎04-19-2018

emm, I don't think you should be root (are you?) and developing in /opt

Could you try as normal user and in the user folder?

0 Kudos
Reply
Highlighted
Contributor
Contributor
1,215 Views
Registered: ‎04-22-2011

@satguy both root and normal user are the same :

 

-normal user :

hpnroot@hpn118:/opt/workspace/DPU$ petalinux-create -t project --template zynqMP -n zcu102_dpu-ubuntu-petalinux
INFO: Create project: zcu102_dpu-ubuntu-petalinux
INFO: New project successfully created in /opt/workspace/DPU/zcu102_dpu-ubuntu-petalinux
hpnroot@hpn118:/opt/workspace/DPU$ cd zcu102_dpu-ubuntu-petalinux/
hpnroot@hpn118:/opt/workspace/DPU/zcu102_dpu-ubuntu-petalinux$ petalinux-config --get-hw-description=../hardware_files
INFO: Getting hardware description...
INFO: Rename zcu102_dpu.xsa to system.xsa
[INFO] generating Kconfig for project
[INFO] menuconfig project
configuration written to /opt/workspace/DPU/zcu102_dpu-ubuntu-petalinux/project-spec/configs/config_zcu102_dpu

*** End of the configuration.
*** Execute 'make' to start the build or try 'make help'.

[INFO] sourcing bitbake
[INFO] generating plnxtool conf
[INFO] generating meta-plnx-generated layer
[INFO] generating user layers
[INFO] generating workspace directory
[INFO] generating bbappends for project . This may take time !
[INFO] generating u-boot configuration files
[INFO] generating kernel configuration files
[INFO] generating kconfig for Rootfs
[INFO] silentconfig rootfs
[INFO] generating petalinux-user-image.bb
hpnroot@hpn118:/opt/workspace/DPU/zcu102_dpu-ubuntu-petalinux$ petalinux-build
[INFO] building project
[INFO] sourcing bitbake
[INFO] generating user layers
[INFO] generating workspace directory
environment: line 2504: build_with_: command not found
ERROR: Failed to build project

 

-root:

root@hpn118:/opt/workspace/DPU# petalinux-create -t project --template zynqMP -n zcu102_dpu-ubuntu-petalinux
INFO: Create project: zcu102_dpu-ubuntu-petalinux
INFO: New project successfully created in /opt/workspace/DPU/zcu102_dpu-ubuntu-petalinux
root@hpn118:/opt/workspace/DPU# cd zcu102_dpu-ubuntu-petalinux/
root@hpn118:/opt/workspace/DPU/zcu102_dpu-ubuntu-petalinux# petalinux-config --get-hw-description=../hardware_files
INFO: Getting hardware description...
INFO: Rename zcu102_dpu.xsa to system.xsa
[INFO] generating Kconfig for project
[INFO] menuconfig project


*** End of the configuration.
*** Execute 'make' to start the build or try 'make help'.

[INFO] sourcing bitbake
[INFO] generating plnxtool conf
[INFO] generating meta-plnx-generated layer
[INFO] generating user layers
[INFO] generating workspace directory
[INFO] generating bbappends for project . This may take time !
[INFO] generating u-boot configuration files
[INFO] generating kernel configuration files
[INFO] generating kconfig for Rootfs
[INFO] silentconfig rootfs
[INFO] generating petalinux-user-image.bb
root@hpn118:/opt/workspace/DPU/zcu102_dpu-ubuntu-petalinux# petalinux-build
[INFO] building project
[INFO] sourcing bitbake
[INFO] generating user layers
[INFO] generating workspace directory
environment: line 2504: build_with_: command not found
ERROR: Failed to build project

0 Kudos
Reply
Highlighted
Explorer
Explorer
1,170 Views
Registered: ‎04-19-2018

 

Check the warning about installing Petalinux tools with regards to user levels.

Have you been able to build any project with that tool? Can you try a basic build with a known BSP (whichever) for a known supported board (that would discard the problem is with the tool)

0 Kudos
Reply
Highlighted
Contributor
Contributor
1,071 Views
Registered: ‎04-22-2011

@satguy yes , I don't know why this one doesn't work 

0 Kudos
Reply
Highlighted
Explorer
Explorer
1,066 Views
Registered: ‎04-19-2018

Well, if you have something that works and something that doesn't, I'd look into the differences. Another approach: take your project with a default config, build it, and change things until it fails. Slow, I know, as it takes a while every time.

Another thing: have you tried petalinux-build -x mrproper? Whenever you build, it reuses things, I've got into errors that vanished after that. Or at least, -x distclean

0 Kudos
Reply
Highlighted
Contributor
Contributor
1,019 Views
Registered: ‎04-22-2011

@satguy well. I worked on this issue for a few days. I couldn't resolve it. Apart from this server, I got several servers in the lab and installed the software on one of them. Now I can see everything is fine and I don't receive this error anymore....

View solution in original post

0 Kudos
Reply
Highlighted
Visitor
Visitor
498 Views
Registered: ‎12-04-2019

I was receiving the same error at first. But later i realized that i didn't point to the exact path of the .xsa when i executed the command: petalinux-config --get-hw... 

With the wrong path: petalinux-config --get-hw-description /run/media/d/Conos_galvo

The correct one: petalinux-config --get-hw-description /run/media/d/Conos_galvo/

Highlighted
Observer
Observer
293 Views
Registered: ‎02-07-2020

I had the same issue and it solved mine too. Thank you for sharing it

0 Kudos
Reply