We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

Showing results for 
Search instead for 
Did you mean: 
Newbie christianm
Registered: ‎05-18-2017

Petalinux 2017.1 kernel 4.9.0 dual cadence gem ps, gem1 -> pl 1000baseX phy.

I am having issues with my zc706 board when I try to run dual gem PS based on the cadence driver.

I ripped the xapp1082 v4.0 bitfile for the ps gem and phy on pl 1000baseX and loaded it in u-boot. Load led lights up.


So I have tried many different variants, nothing seems to work.

Single gem works just fine.


1. Dual gems, with their own mdio pinctrl definition.

Result: No go, kernel complains that the pinctrl for gem0 is the same as gem1. It's already used. No wonder. Only one master can exist on the bus.


2. Tried a dozen variants of moving about pinctrl definitions, phy definitions and whatnots.

Result: No go, whichever way I turn, somthing breaks.


3. Tried patching the cadence driver with the provided 2017.1 mdio-bus (macb_mdio.c). Declared a mdio definition, and phys. Pointed the gem phy declarations to the phy handles.

Result: Gem0 and gem1 come up fine, mdiobus registers two phys. But accessing the interfaces complains that no phy is found for either interface. Not even gem0.


Any hints would be much appreciated.

0 Kudos
1 Reply
Newbie abenilov
Registered: ‎11-13-2017

Re: Petalinux 2017.1 kernel 4.9.0 dual cadence gem ps, gem1 -> pl 1000baseX phy.

Hi @christianm, 

I am having the exact same problem with 703-based custom board. Did you manage to find a solution by any chance?

0 Kudos