cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
5,205 Views
Registered: ‎06-07-2017

Petalinux 2017.1 petalinux-config not working

Jump to solution

Hi

I am trying too boot my ZCU102 with a static IP, so that i can start the NFS configuration on it. I tried the following steps:

1. petalinux-create -t project -s zip/xilinx-zcu102-zu9-es2-rev1.0-v2017.1-final.bsp --name testproj

2. petalinux-config

    > -*- Subsystem AUTO Hardware Settings ---> Ethernet Settings --->

[ ] Obtain IP address automatically
  (192.168.69.2) Static IP address
 (255.255.255.0) Static IP netmask
 (192.168.69.1) Static IP gateway

    > Exit > Save Changes

3. petalinux-build

4. petalinux-package --boot --fsbl images/linux/zynqmp_fsbl.elf --fpga images/linux/design_1_wrapper.bit --pmufw images/linux/pmufw.elf --u-boot

 

My Workstation already has an Ethernet interface at 192.168.69.1 When i copy over the BOOT.BIN and image.ub to the SDCARD and boot, the ifconfig on the board gives me this:

 

root@plnx_aarch64:~# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:0A:35:00:22:01  
          inet6 addr: fe80::20a:35ff:fe00:2201%4879704/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:690 errors:0 dropped:1 overruns:0 frame:0
          TX packets:9 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:118478 (115.7 KiB)  TX bytes:1534 (1.4 KiB)
          Interrupt:31 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1%4879704/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

 If i then manually set up the eth0 interface as follows:

ifconfig eth0 192.168.69.2 netmask 255.255.255.0
route add default gw 192.168.69.1 eth0

I can ping my Workstation from the board and back.

 

After this, if i go back to the project folder and do a petalinux-config, it still shows the options as i left them, with the IP address configuration set to manual with the manual IP subnet and gateway.

 

How do I make sure that the configuration i set in the petalinux-config actually takes effect?

I need to be able to set the static ethernet IP address in order to use the NFS!!!

 

Board: ZCU102-ES2

Petalinux: 2017.1

Vivado: 2017.1

SDK: 2017.1

BSP: 2017.1

0 Kudos
1 Solution

Accepted Solutions
Highlighted
8,726 Views
Registered: ‎12-07-2016
5 Replies
Highlighted
8,727 Views
Registered: ‎12-07-2016
Highlighted
Moderator
Moderator
5,159 Views
Registered: ‎12-04-2016

Hi 

 

If you want to set the static IP in petalinux 2017.1, here is the veified steps posted in this link along with attached recipe file:

https://forums.xilinx.com/t5/Embedded-Linux/No-static-IP-in-PetaLinux-2016-4/td-p/743272

 

 

Best Regards

Shabbir

Highlighted
Visitor
Visitor
5,142 Views
Registered: ‎06-07-2017
Hey thanks so much! The static IP worked after I added the line in the petalinuxbsp.conf file.
0 Kudos
Highlighted
Visitor
Visitor
5,142 Views
Registered: ‎06-07-2017
Thank you! the files you provided worked!
0 Kudos
Highlighted
Moderator
Moderator
5,130 Views
Registered: ‎12-04-2016

Hi

 

Thanks for the update. 

 

Can you please accept this as a solution, so that this will help others.

 

 

Best Regards

Shabbir

0 Kudos