cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Contributor
Contributor
2,089 Views
Registered: ‎11-17-2014

Petalinux 2017.2 - OS Boot taking longer than usual on QSPI

Jump to solution

I just updated from Petalinux 2016.3 to 2017.2 and I'm noticing that it is taking over a minute for the operating system to start after u-boot starts reading the image on the QSPI flash. 

 

device 0 offset 0x620000, size 0xa80000

... a minute or two later

SF: 11010048 bytes @ 0x620000 Read: OK

... kernel loads immediately

I don't know the exact issue, since Petalinux 2017.2 is configured vastly different from 2016.3. Is there a petalinux-config, u-boot, or kernel setting that I need to change to get the image to boot immediately when u-boot goes to the image address? Petalinux 2016.3 and earlier versions I've used always boot immediately once u-boot goes to the image offset. The offset for both versions are set to the same address.

0 Kudos
Reply
1 Solution

Accepted Solutions
Contributor
Contributor
3,754 Views
Registered: ‎11-17-2014

Found my issue, was a small mix up in a define inside u-boot.

 

https://www.xilinx.com/support/answers/69382.html

View solution in original post

0 Kudos
Reply
1 Reply
Contributor
Contributor
3,755 Views
Registered: ‎11-17-2014

Found my issue, was a small mix up in a define inside u-boot.

 

https://www.xilinx.com/support/answers/69382.html

View solution in original post

0 Kudos
Reply