UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Scholar ronnywebers
Scholar
1,169 Views
Registered: ‎10-10-2014

Petalinux 2017.2 says 'The 'arm-generic-fdt-plnx' machine has been deprecated'

I'm trying to boot a petalinux image on QEMU :

 

* petalinux-build

* petalinux-package --prebuilt

* petalinux-boot --qemu --prebuilt 3

 

Upon launching QEMU, I get this output :

 

INFO: The image provided is a zImage
INFO: Set QEMU tftp to /home/zynqdev/Zynq/2017_2/petalinux/drfa/images/linux 
INFO: TCP PORT is free 
INFO: Starting arm QEMU
INFO:  qemu-system-aarch64 -M arm-generic-fdt-plnx -machine linux=on   -serial /dev/null -serial mon:stdio -display none -kernel /home/zynqdev/Zynq/2017_2/petalinux/drfa/build/qemu_image.elf -gdb tcp::9000 -dtb /home/zynqdev/Zynq/2017_2/petalinux/drfa/pre-built/linux/images/system.dtb  -net nic,vlan=1 -net user,vlan=1,tftp=/home/zynqdev/Zynq/2017_2/petalinux/drfa/images/linux -net nic -device loader,addr=0xf8000008,data=0xDF0D,data-len=4 -device loader,addr=0xf8000140,data=0x00500801,data-len=4 -device loader,addr=0xf800012c,data=0x1ed044d,data-len=4 -device loader,addr=0xf8000108,data=0x0001e008,data-len=4    
The 'arm-generic-fdt-plnx' machine has been deprecated. Please use 'arm-generic-fdt-7series' instead.
**
ERROR:/build/ssw/petalinux/jenkins/new_build_src_2017.2/qemu/qom/object.c:1576:object_get_canonical_path_component: assertion failed: (obj)
petalinux-qemu-boot: line 823: 81029 Aborted                 (core dumped) $QEMU_DEBUG ${qemu_cmd} ${qemu_mach} ${nic_list} ${qemu_serial} ${qemu_display} ${qemu_img_opt} -gdb tcp::${start_port} ${dtb_option} ${slirp_option} ${zynq_fsbl_args} ${extra_args} ${aarch64_beta2_args} ${mem_option}

I think this is the issue :

 

The 'arm-generic-fdt-plnx' machine has been deprecated. Please use 'arm-generic-fdt-7series' instead 

can someone tell me what to do?

** kudo if the answer was helpful. Accept as solution if your question is answered **
0 Kudos
4 Replies
Moderator
Moderator
1,121 Views
Registered: ‎10-06-2016

Re: Petalinux 2017.2 says 'The 'arm-generic-fdt-plnx' machine has been deprecated'

Hi @ronnywebers

 

There is already an existing post where it seems that the same issue is discussed :)

 

I just tested in my end using ZC702 BSP package and pre-build kernel ($petalinux-boot --qemu --prebuilt 3) and although I do get the same warning message the system seems to boot properly.

INFO: The image provided is a zImage                                                     
INFO: Set QEMU tftp to /home/ibaie/Workspace/Forum/qemu/zc702/pre-built/linux/images/    
INFO: TCP PORT is free                                                                   
INFO: Starting arm QEMU                                                                  
INFO:  qemu-system-aarch64 -M arm-generic-fdt-plnx -machine linux=on   -serial /dev/null -serial mon:stdio -display none -kernel /home/ibaie/Workspace/Forum/qemu/zc702/build/qemu_image.elf -gdb tcp::9000 -dtb /home/ibaie/Workspace/Forum/qemu/zc702/pre-built/linux/images/system.dtb  -net nic,vlan=1 -net user,vlan=1,tftp=/home/ibaie/Workspace/Forum/qemu/zc702/pre-built/linux/images/ -net nic -device loader,addr=0xf8000008,data=0xDF0D,data-len=4 -device loader,addr=0xf8000140,data=0x00500801,data-len=4 -device loader,addr=0xf800012c,data=0x1ed044d,data-len=4 -device loader,addr=0xf8000108,data=0x0001e008,data-len=4                                                                    
The 'arm-generic-fdt-plnx' machine has been deprecated. Please use 'arm-generic-fdt-7series' instead.                                                                                                                                
Warning: vlan 0 is not connected to host network                                                                                                                                                                                     
Uncompressing Linux... done, booting the kernel.                                                                                                                                                                                     
Booting Linux on physical CPU 0x0          

Although you posted your commands how are you buildling the petalinux project? I mean, custom HDF file or a BSP?

 

Regards

Ibai


Ibai
Don’t forget to reply, kudo, and accept as solution.
Scholar ronnywebers
Scholar
1,096 Views
Registered: ‎10-10-2014

Re: Petalinux 2017.2 says 'The 'arm-generic-fdt-plnx' machine has been deprecated'

thanks @ibaie, it looks like this guy has the same issue.

 

I'm using a custom .hdf file, I can share it if you want. I'll try with a BSP and see if it makes any difference.

 

in my case petalinux kind of 'hangs' in the terminal, I can see the terminal responding in a strange way, and I need to close it and open a new one.

 

** kudo if the answer was helpful. Accept as solution if your question is answered **
0 Kudos
Moderator
Moderator
1,085 Views
Registered: ‎09-12-2007

Re: Petalinux 2017.2 says 'The 'arm-generic-fdt-plnx' machine has been deprecated'

you should use the steps

petalinux-build -t project -s <path to BSP>

cd <project dir>

petalinux-config --get_hw_description=<path to hdf>

continue as normal

Scholar ronnywebers
Scholar
1,050 Views
Registered: ‎10-10-2014

Re: Petalinux 2017.2 says 'The 'arm-generic-fdt-plnx' machine has been deprecated'

@stephenm@ibaie

 

I'm getting back to this issue, as I'd like to start using QEMU to save some time during development.

 

I'll repeat the steps that I do :

# 1 - source the tools
source /opt/pkg/petalinux/settings.sh

# 2 - create the petalinux project & cd into it
petalinux-create --type project --template zynq --name myproject
cd myproject

# 3 - copy the hdf file  (from the Desktop, it's generated on another machine) into the project
cp /home/zynqdev/Desktop/design_1_wrapper.hdf .

# 4 - init the project -> launches the config menu -> just exit
petalinux-config --get-hw-description

# 5 - build
petalinux-build

# 6 - create pre-built package (for booting on QEMU)
petalinux-package --prebuilt

# 7 - boot on QEMU
petalinux-boot --qemu --prebuilt 3

-> now with my .hdf file of my full project this gives the error mentioned in my question above. The .hdf file is built for a Picozed board.

 

I tried again, with a very simple project on the Zedboard : just a Zynq + AXI GPIO, connected to the 5 switches on the zedboard. Then generate bitstream, export .hdf -> this does work !! ... QEMU boots, I can login and see for example the axi gpio under /sys/class/gpio 

 

note that I do get the 'deprecated' warning too here, but the system boots ... 

 

any suggestions that I can try?

 

my custom (AXI) IP uses the UIO driver, could that be causing issues?

 

 

 

 

** kudo if the answer was helpful. Accept as solution if your question is answered **
0 Kudos