UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor avek
Visitor
1,034 Views
Registered: ‎04-04-2018

Petalinux 2017.4 Using Linux kernel higher than 4.9

Hello, I am pretty new to petalinux and Embedded Linux development generally, so, please, dont beat me heavily)

 

   I'm trying to get bootable SD with latest version of linux available for Zynq UltraScale+. I use petalinux 2017.4 and have selected Xilinx git rep as a source for Linux kernel (git://github.com/Xilinx/linux-xlnx.git) in peralinux-config menu

(Linux components selection->Linux kernel(remote)). The latest Linux version available is 4.14.

 

I also use this link

http://www.wiki.xilinx.com/Zynq+UltraScale%EF%BC%8B+MPSoC+Ubuntu+part+2+-+Building+and+Running+the+Ubuntu+Desktop+From+Sources

 

as a road map. All steps before

   petalinux-build

seems to have passed successfully. When trying to build i'm getting such an error:

 

ERROR: linux-xlnx-4.9-xilinx-v2017.4+gitAUTOINC+ccb9ad68f9-r0 do_kernel_version_sanity_check: Package Version (4.9-xilinx-v2017.4+gitAUTOINC+ccb9ad68f9) does not match of kernel being built (4.14). Please update the PV variable to match the kernel source.

It seems that I should download some package or patch, not just changing some variable's value, right?

 

How can I update petalinux tools to use newer kernel? Is it possible?

Thanks

 

 

 

  

0 Kudos
3 Replies
Contributor
Contributor
1,012 Views
Registered: ‎09-07-2016

Re: Petalinux 2017.4 Using Linux kernel higher than 4.9

I am struggeling with a similar problem (Integrating an older kernel in petalinux 2017.2) but haven't been succesfull either. I also would really appreciate it if someone who has done this before could sketch a basic workflow.

0 Kudos
Moderator
Moderator
998 Views
Registered: ‎12-04-2016

Re: Petalinux 2017.4 Using Linux kernel higher than 4.9

Hi

 

Could you please check if this patch helps you ?

http://cgit.openembedded.org/openembedded-core/commit/?id=1b6a3c17874ead7ee0957e67329aa3bd019fa129

 

 

Best Regards

Shabbir

0 Kudos
Visitor avek
Visitor
920 Views
Registered: ‎04-04-2018

Re: Petalinux 2017.4 Using Linux kernel higher than 4.9

Thanks for rapid reply! But it didn't work for me.

 

 

 I used another solution, that partly solved the problem (it may seem strange, but it works).

 

   1. I have renamed file <petalinux dir> / components / yocto / source / aarch64 / layers / meta-xilinx / recipes- kernel / linux / linux-xlnx_4.9.bb to linux-xlnx_4.14.bb and changed LINUX_VERSION to 4.14. 

It seems that it is not anough, but I have not investigate this yet.

build process completes without an error, and prints only warnings, that preferred kernel 4.9 is not available and that it uses 4.14,

but i still cant get working kernel.

 

 

 

0 Kudos