cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Observer
Observer
1,045 Views
Registered: ‎11-27-2017

Petalinux 2018.2 Build Fail on Ubuntu18.04.1

Jump to solution

First, When I build Petalinux, I get the following error message.

How can we solve it?

 

[INFO] building project
[INFO] sourcing bitbake
SDK environment now set up; additionally you may now run devtool to perform development tasks.
Run devtool --help for further details.

### Shell environment set up for builds. ###

You can now run 'bitbake <target>'

Common targets are:
    core-image-minimal
    core-image-sato
    meta-toolchain
    meta-ide-support

You can also run generated qemu images with a command like 'runqemu qemux86'
NOTE: Starting bitbake server...
INFO: Adding user layer: /home/fpga/ULTRON_V_1_2_0/project-spec/meta-user
NOTE: Starting bitbake server...
ERROR:  OE-core's config sanity checker detected a potential misconfiguration.
    Either fix the cause of this error or at your own risk disable the checker (see sanity.conf).
    Following is the list of potential problems / advisories:

    You system needs to support the en_US.UTF-8 locale.
ERROR: Failed to build project

 

And, I would like to run it on the ZU17EG product, but I do not have the corresponding BSP information.
Is it ok to use ZU9EG? PS's ARM Core information is the same, so it does not seem to be a problem.

0 Kudos
Reply
1 Solution

Accepted Solutions
Contributor
Contributor
1,021 Views
Registered: ‎09-14-2017

Ubuntu 18.04 is not supported by Petalinux 2018.2, there has been multiple posts about that in the forums. The supported distributions for 2018.2 are:

- Red Hat Enterprise Workstation/Server 7.2, 7.3, 7.4 (64-bit)
- CentOS 7.2, 7.3, 7.4 (64-bit)
- Ubuntu Linux 16.04.3 (64-bit)

 

--Kim

View solution in original post

0 Kudos
Reply
1 Reply
Contributor
Contributor
1,022 Views
Registered: ‎09-14-2017

Ubuntu 18.04 is not supported by Petalinux 2018.2, there has been multiple posts about that in the forums. The supported distributions for 2018.2 are:

- Red Hat Enterprise Workstation/Server 7.2, 7.3, 7.4 (64-bit)
- CentOS 7.2, 7.3, 7.4 (64-bit)
- Ubuntu Linux 16.04.3 (64-bit)

 

--Kim

View solution in original post

0 Kudos
Reply