cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
kharalan
Visitor
Visitor
2,641 Views
Registered: ‎09-27-2018

Petalinux 2018.2 on ZCU102 reboot problem

Hi,

I'm having a problem with the reboot command on ZCU102 and Petalinux 2018.2.

The reboot command does not work every time. Some time it reboots the board, and some time it gets stuck like this:

 

root@ptlinux:~# reboot

Broadcast message from root@ptlinux (ttyPS0) (Thu Nov 1 23:27:17 20ÃJÒ

The system is going down for reboot NOW!
INIT: Sending processes the TERM signal
root@ptlinux:~# Stopping Dropbear SSH server: stopped /usr/sbin/dropbear (pid 2348)
dropbear.
Stopping syslogd/klogd: stopped syslogd (pid 2356)
stopped klogd (pid 2359)
done
Stopping tcf-agent: OK
Deconfiguring network interfaces... [10776.229208] macb ff0e0000.ethernet: gem-ptp-timer ptp clock unregistered.
done.
Sending all processes the TERM signal...
logout
[10777.004471] macb ff0e0000.ethernet eth0: link down
Sending all processes the KILL signal...
Unmounting remote filesystems...
Deactivating swap...
Unmounting local filesystems...
Rebooting... [10783.546706] reboot: Restarting system

 

Some time the reboot will work several times in a row, other times will not work and I need to press the POR button. I have not found any pattern. I need a reliable way to reboot the system when I load new FPGA or Linux image. Any suggestions?

 

Thanks!

 

 

0 Kudos
6 Replies
gudishak
Moderator
Moderator
2,612 Views
Registered: ‎06-27-2017

What is the boot mode SD or QSPI ?
Best Regards
Kranthi
--------------------------
Don't forget to reply, kudo, and accept as solution.
0 Kudos
kharalan
Visitor
Visitor
2,582 Views
Registered: ‎09-27-2018

The boot mode is SD.

0 Kudos
sandeepg
Moderator
Moderator
2,578 Views
Registered: ‎04-24-2017

Hi @kharalan,

Have you connected with JTAG cable while rebooting?

Thanks,
Sandeep
PetaLinux Yocto | Embedded SW Support

---------------------------------------------------------------------------
Don’t forget to Reply, Kudo, and Accept as Solution.
---------------------------------------------------------------------------
0 Kudos
kharalan
Visitor
Visitor
2,575 Views
Registered: ‎09-27-2018

Yes - it looks like the reboot is not working after I connect with the JTAG to the FPGA. If I don't have the JTAG cable connected or do not open the HW manager in Vivado the reboot command works fine.

0 Kudos
sandeepg
Moderator
Moderator
2,573 Views
Registered: ‎04-24-2017

Hi @kharalan,

Yes this is a known issue refer this AR for work around https://www.xilinx.com/support/answers/69143.html

I would suggest to walk through release notes https://www.xilinx.com/support/answers/71201.html when you start build a project.

Thanks,
Sandeep
PetaLinux Yocto | Embedded SW Support

---------------------------------------------------------------------------
Don’t forget to Reply, Kudo, and Accept as Solution.
---------------------------------------------------------------------------
0 Kudos
wangyudi
Observer
Observer
1,515 Views
Registered: ‎09-19-2018

Hi  kharalan , I encountered the same problem. Did https://www.xilinx.com/support/answers/69143.html work for you?

0 Kudos