UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
481 Views
Registered: ‎10-24-2019

Petalinux 2018.3 failed to build

Jump to solution

Hi,

When I try to build (petalinux-build) my petalinux project by Petalinux2018.3, I get device-tree build errors. I attached the log file.

Best regards,

 

 

0 Kudos
1 Solution

Accepted Solutions
Moderator
Moderator
249 Views
Registered: ‎09-12-2007

Re: Petalinux 2018.3 failed to build

Jump to solution

This is fixed in the latest DTG version. I have created a patch for 2018.3 that you can use. I tested this in 2018.3 and it works for me

 

For help using the patch, see the wiki here:

https://xilinx-wiki.atlassian.net/wiki/spaces/A/pages/136904764/Creating+Devicetree+from+Devicetree+Generator+for+Zynq+Ultrascale+and+Zynq+7000

View solution in original post

0 Kudos
6 Replies
480 Views
Registered: ‎10-24-2019

Re: Petalinux 2018.3 failed to build

Jump to solution
 
Screenshot from 2020-02-14 17-43-30.png
Screenshot from 2020-02-14 17-43-57.png
0 Kudos
Xilinx Employee
Xilinx Employee
451 Views
Registered: ‎01-21-2008

Re: Petalinux 2018.3 failed to build

Jump to solution

Hi aysenurakinci805@gmail.com 

Please have a look https://www.xilinx.com/support/answers/72007.html & https://www.xilinx.com/support/answers/72366.html

If this is not fixed then send me the HDF file to have a look.

0 Kudos
266 Views
Registered: ‎10-24-2019

Re: Petalinux 2018.3 failed to build

Jump to solution

Hi Jadhavs,

Thank you for interest. I tried but it doesn't work. My HDF file is attached.

Best regards,

Ayse Nur

0 Kudos
Moderator
Moderator
250 Views
Registered: ‎09-12-2007

Re: Petalinux 2018.3 failed to build

Jump to solution

This is fixed in the latest DTG version. I have created a patch for 2018.3 that you can use. I tested this in 2018.3 and it works for me

 

For help using the patch, see the wiki here:

https://xilinx-wiki.atlassian.net/wiki/spaces/A/pages/136904764/Creating+Devicetree+from+Devicetree+Generator+for+Zynq+Ultrascale+and+Zynq+7000

View solution in original post

0 Kudos
210 Views
Registered: ‎10-24-2019

Re: Petalinux 2018.3 failed to build

Jump to solution

Thank you for helping Stephenm, it worked.

Best regards,

0 Kudos
Moderator
Moderator
205 Views
Registered: ‎09-12-2007

Re: Petalinux 2018.3 failed to build

Jump to solution

Please mark this as solved please

0 Kudos