cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Observer
Observer
593 Views
Registered: ‎06-01-2016

Petalinux 2019.2 /dev/mem

Hi,

I recently upgraded to Petalinux 2019.2, and I used to be able to access /dev/mem as root on previous version. I did find a previous post that asked to get in to the Kernel Hacking menu option to disable devmem filtering, but that didn't help any, as it was already disabled. Does anyone have any other idea? I have the character device enabled in the  kernel config, as well as disabling security options (I believe) that protects /dev/mem.


Thanks,

Rob

0 Kudos
Reply
3 Replies
Observer
Observer
573 Views
Registered: ‎06-01-2016

I need to clarify a bit. I have devices (PL space devices) that I can access through /dev/mem && peek/poke. However, getting to Zynq PS registers (GPIO, I2C, etc.) seems to not be possible anymore.
0 Kudos
Reply
Explorer
Explorer
497 Views
Registered: ‎03-21-2019

In the kernel configuration, there's an option called strict devmem filtering (or something along those lines.) You could turn that off and see if it makes a difference

0 Kudos
Reply
Observer
Observer
218 Views
Registered: ‎06-01-2016

I tried, but no dice.
0 Kudos
Reply