cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
11,019 Views
Registered: ‎08-12-2015

Petalinux SD card annoying problem

Hello,

 

I have a problem with my Petalinux 2015.2 and automounting SD card. I'm working on MicroZed using Vivado 2015.2 and SDK.

This two lines (at booting kernel) really annoys me. But system is booting from SD card properly.

 

mkdir: can't create directory '/run/media/mmcblk0p1' : No such file or directory
mount: mounting /dev/mmcblk0p1 on run/media/mmcblk0p1 failed: No such file or directory

 

I tried to do some apps with changed Makefile. I had an idea to force creating that path by:

 

install: $(APP)
           $(TARGETINST) -d $(APP) /run/media/$(APP)

but it doesn't seem work.

Have you got any idea how to deal with it? I got stuck so I would be grateful for any help..

 

Thank you in advance,

tymonz

0 Kudos
7 Replies
Highlighted
Xilinx Employee
Xilinx Employee
11,014 Views
Registered: ‎08-01-2008

You can check this ARs
http://www.xilinx.com/support/answers/60384.html
Thanks and Regards
Balkrishan
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
0 Kudos
Highlighted
Visitor
Visitor
10,925 Views
Registered: ‎08-12-2015

Hi balkris,

 

I really appreciate your help. I followed yours instructions and it seems that I can create any folder in any directory (for example /bin) except in "/run" folder.

 

My makefile looks like this:

 

all: install

.PHONY: install

install: $(APP)
           rsync -ar ./up/ $(TARGERDIR)/bin/

and it worked, but if I change path to /run there is no folder at /run on petalinux .

I tried to gave some correct permissions using before my rsync line but it didn't worked too..

 

-chmod -p 0755 $(TARGETDIR)/run

 

Best regards,

tymonz

0 Kudos
Highlighted
Visitor
Visitor
10,796 Views
Registered: ‎08-12-2015

Hi,

 

So maybe is there any other ideas how to fix this? Or anyone can tell me if this is normal behavior?

After startup when I try mount SD card I got this message:

 

FAT-fs (mmcblk0p1): Volume was not properly unmounted. Some data my be corrupt. Please run fsck.

Thanks.

tymonz

0 Kudos
Highlighted
Scholar
Scholar
10,781 Views
Registered: ‎05-28-2013

It is pretty normal, unfortunately. It is complaining that the filesystem was not cleanly shut down. To avoid this, you have to "umount /dev/mmcblk0p1" during shutdown, or before the SD card is ejected.

You can make the warning go away by running "fsck.vfat /dev/mmcblk0p1". Be sure to un-mount the filesystem before running that.

However unless you always shut down the board cleanly, the warning will come back. Thus most people just tend to ignore it.

0 Kudos
Highlighted
Visitor
Visitor
10,722 Views
Registered: ‎08-12-2015

Hi rfs613,

 

thanks for your explanation, I really appreciate it.

As you say I will ignore it. Just wanted to know the cause of this warning and now you've helped me.

 

Best regards,

tymonz

0 Kudos
Highlighted
Visitor
Visitor
10,706 Views
Registered: ‎08-05-2015

My petalinux doesn't have 'fsck.vfat'.  Is there a config option to add it?

 

--Jeff

 

0 Kudos
Highlighted
Scholar
Scholar
10,700 Views
Registered: ‎05-28-2013

Apologies, it is actually fsck.fat (not vfat). It comes from the dosfstools package.

 

I happen to use use Buildroot, where the relevant config option is BR2_PACKAGE_DOSFSTOOLS_MKFS_FAT, but I am pretty certain it should be available in PetaLinux as well.

 

-R

0 Kudos