We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

Showing results for 
Search instead for 
Did you mean: 
Visitor crescent1973
Registered: ‎10-17-2018

Petalinux-boot problem with JTAG: OCM is not enabled

Hello guys,

I'm facing this problem for which I search the forums but can't get a good solution.

I'm now working with Petalinux 2015.2.1, after I prepared everything, I used "petalinux-boot --jtag --fpga --bitstream <my bitstream file> --kernel", just as the operation I did when I used Petalinux 2015.4 a few months ago, but there comes the error message:

Failed to download <work path>/images/linux/zImage
Error in startup script:
OCM is not enabled at 0x00030000. Invalid address

I never encountered this error before! Then I tried to do the same booting progress step by step, firstly I did "--fpga --bitstream <my bitstream file>", then "--u-boot" and finally I did "--kernel", my device boot successfully! I also try to boot with "prebuilt" method and it succeeded to boot, too.

I'm curious why this error will appear. Is there anything wrong with my configs of kernel or my device-tree files? Or this is just a script bug in earlier version of Petalinux?

I will be appreciate for any relevant information!

0 Kudos
1 Reply
Visitor crescent1973
Registered: ‎10-17-2018

Re: Petalinux-boot problem with JTAG: OCM is not enabled

OK, there are more things about it.

I build the same project with Petalinux 2015.4 and SDK 2015.4, the problem didn't occur. I noticed some differences between two version of Petalinux and SDK:

1. Manual config of u-boot is not available in version 2015.2.1 but it can be done in version 2015.4;

2. After the operation "petalinux-package --boot --fsbl ./image/linux/zynq_fsbl.elf --fpga <BITSTREAM>" was done, there prints some information:

------------version 2015.2.1-----------------

  INFO: Generating zynq binary package BOOT.BIN...
  INFO: Binary is ready.

------------version 2015.4-------------------

  INFO: Getting system flash information...
  INFO: File in BOOT BIN: "<work path>/images/linux/zynq_fsbl.elf"
  INFO: File in BOOT BIN: "<work path>/<BITSTREAM file>"
  INFO: Generating zynq binary package BOOT.BIN...
  INFO: Binary is ready.


Besides, I check the error message once more, it seems that the error is more about the SDK, or , XSDB tools rather than Petalinux because when the error occurs it shows the XSDB log to me.

FYI, I found this topic about the same problem:


2 years have passed but no one found a solution to this XD.

0 Kudos