UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor beth777
Visitor
388 Views
Registered: ‎08-06-2018

Petalinux build: INIT: Id "1" respawning too fast: disable for 5 mins

Hi All

I have built a linux kernel using petalinux 2017.4 and the following error is coming up when the kernel is running:

INIT: Id "1" respawning too fast: disable for 5 mins

which seems to be related to thefollowing in the /var/log/messages file:

getty cant open '/dev/tty1'

I followed this solution:

https://forums.xilinx.com/t5/Embedded-Linux/No-option-in-PetaLinux-2016-4-to-disable-getty/td-p/743985

but it has not fixed the problem.

Any advice would be most welcome.

Thanks

0 Kudos
1 Reply
Moderator
Moderator
329 Views
Registered: ‎04-24-2017

Re: Petalinux build: INIT: Id "1" respawning too fast: disable for 5 mins

Hi @beth777,

I don't see this issue in 2017.2 onwards.

In order to remove this message in kernel logs, add the following bitbake variable in <plnx-proj-root>/project-spec/meta-user/conf/petalinuxbsp.conf

SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
Thanks,
Sandeep
PetaLinux Yocto | Embedded SW Support

---------------------------------------------------------------------------
Don’t forget to Reply, Kudo, and Accept as Solution.
---------------------------------------------------------------------------
0 Kudos