UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer adithyab
Observer
374 Views
Registered: ‎10-01-2018

Petalinux build takes too long

I have started using petalinux (2018.2) for generation of linux images.

I thing I find annoying is that the build is very slow. Even if I change just one line in kernel, build easily takes 15~20 minutes. Even something like 'petalinux-build -c kernel' does not seem to make any difference.

Is there any way to speed up the build?

0 Kudos
5 Replies
Moderator
Moderator
364 Views
Registered: ‎09-12-2007

Re: Petalinux build takes too long

Moderator
Moderator
344 Views
Registered: ‎12-04-2016

Re: Petalinux build takes too long

Hi @adithyab

Please refer to UG1144 guide below (Page 33) which explains Build optimization techniques

https://www.xilinx.com/support/documentation/sw_manuals/xilinx2018_3/ug1144-petalinux-tools-reference-guide.pdf

 

 

Best Regards

Shabbir

Observer adithyab
Observer
322 Views
Registered: ‎10-01-2018

Re: Petalinux build takes too long

@shabbirk

Thanks.

I have removed the fsbl and pmu as I don't need it to build every time.

I did see a parallel thread tab in yocto settings which was blank. I have set both the number of threads and parallel make to 4 (number of cpu cores). I don't see that this is mentioned in the user guide.

local Sstate looks like interesting option. I will need some time to download and set it up.

0 Kudos
Highlighted
Explorer
Explorer
311 Views
Registered: ‎10-21-2015

Re: Petalinux build takes too long

Hi 

See Building Ignoring Dependencies at p35 of ug1144

petalinux-build -b recipe ignore depencies of the recipe

You can set local sstate location from Yocto Setting using petalinux-config

 

0 Kudos
Newbie evelyn233
Newbie
254 Views
Registered: ‎03-01-2019

Re: Petalinux build takes too long

I did see a parallel thread tab in yocto settings which was blank. I have set both the number of threads and parallel make to 4 (number of cpu cores). I don't see that this is mentioned in the user guide.

0 Kudos