UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
5,023 Views
Registered: ‎04-20-2011

Petalinux uboot problem - kernel_image not set

Using Petalinux 2014.2 

selecting boot from SD card, kernel image file name = image.ub

 

When booting from SD card here is what I get from uboot prompt:

 

-----------------------------------------------------------

U-Boot 2014.01 (Aug 22 2014 - 12:29:34)

Memory: ECC disabled
DRAM: 1 GiB
MMC: zynq_sdhci: 0
Using default environment

In: serial
Out: serial
Err: serial
Net: Gem.e000b000
U-BOOT for 2d227_bare_system

Gem.e000b000 Waiting for PHY auto negotiation to complete..... done
BOOTP broadcast 1
DHCP client bound to address 10.0.0.129
Hit any key to stop autoboot: 0
Gem.e000b000:0 is connected to Gem.e000b000. Reconnecting to Gem.e000b000
Gem.e000b000 Waiting for PHY auto negotiation to complete....... done
*** Warning: no boot file name; using '0A000081.img'
Using Gem.e000b000 device
TFTP from server 10.0.0.106; our IP address is 10.0.0.129
Filename '0A000081.img'.
-----------------------------------------------------------

 

 

ENV : 

-----------------------------------------------------------

U-Boot-PetaLinux> printenv
autoload=no
baudrate=115200
bootcmd=run default_bootcmd
bootdelay=4
clobstart=0x01000000
console=console=ttyPS0,115200
default_bootcmd=tftp ${netstart} ${kernel_img} && bootm ${netstart}
dnsip=10.0.0.3
dtbnetstart=0x02800000
ethact=Gem.e000b000
ethaddr=00:0a:35:00:ae:ba
fault=echo ${img} image size is greater than allocated place - partition ${img}
is NOT UPDATED
gatewayip=10.0.0.3
hostname=2d227_bare_system
ipaddr=10.0.0.129
loadaddr=0x01000000
nc=setenv stdout nc;setenv stdin nc;
netboot=tftp ${netstart} ${kernel_img} && bootm
netmask=255.255.255.0
netstart=0x01000000
psserial0=setenv stdout ttyPS0;setenv stdin ttyPS0
sdboot=echo boot Petalinux; mmcinfo && fatload mmc 0 ${netstart} ${kernel_img} &
& bootm
serial=setenv stdout serial;setenv stdin serial
serverip=10.0.0.106
test_crc=if imi ${clobstart}; then run test_img; else echo ${img} Bad CRC - ${im
g} is NOT UPDATED; fi
test_img=setenv var "if test ${filesize} -gt ${psize}; then run fault; else run
${installcmd}; fi"; run var; setenv var

Environment size: 1060/16380 bytes
U-Boot-PetaLinux>

-----------------------------------------------------------

 

Obviously kernel_img is not set, so setting this in uboot to image.ub (like in petalinux config) and then running boot command, it works...

 

In 2013.10 kernel_img was set by default to image.ub and there was no problem

 

Is this a bug , or is there a specific configuration I must do ?

0 Kudos
1 Reply
Xilinx Employee
Xilinx Employee
5,012 Views
Registered: ‎12-17-2007

Re: Petalinux uboot problem - kernel_image not set

In 2014.2 it is now needed to specify that the SD card is being used in multiple places.

Double-check that the following are configured for SD card:

MenuConfig --> Subsystem AUTO Hardware Settings --> Advanced bootable images storage Settings --> boot image settings

MenuConfig --> Subsystem AUTO Hardware Settings --> Advanced bootable images storage Settings --> kernel image settings
-------------------------------------------
this space intentionally left blank
0 Kudos