cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Adventurer
Adventurer
1,260 Views
Registered: ‎08-16-2017

Petalinux/yocto preferred version

Jump to solution

Hi,

In petalinux-config -c rootfs I would like to install opencv however, selecting the package automaltically sets preferred version to latest. I would like to use:

 

PREFERRED_VERSION_opencv ="2.4"

 but I am unsure which project file should this be included into? as most of the conf files are automatically generated.

 

0 Kudos
1 Solution

Accepted Solutions
Moderator
Moderator
1,337 Views
Registered: ‎04-24-2017

Hi @ziladdev,

 

Which version of petalinux are you using?

 

 

In 2018.x petalinux/yocto rocko release it is shipped with opencv 3.3 http://cgit.openembedded.org/meta-openembedded/tree/meta-oe/recipes-support/opencv/opencv_3.3.bb?h=rocko

 

You can't use 2.4 as suggested by @shabbirk it is blacklisted from Yocto community http://layers.openembedded.org/layerindex/recipe/54289/ 

Thanks,
Sandeep
PetaLinux Yocto | Embedded SW Support

---------------------------------------------------------------------------
Don’t forget to Reply, Kudo, and Accept as Solution.
---------------------------------------------------------------------------

View solution in original post

3 Replies
Highlighted
Moderator
Moderator
1,245 Views
Registered: ‎12-04-2016

Hi

 

Try adding in project-spec/meta-user/conf/petalinuxbsp.conf

 

 

Best Regards

Shabbir

Moderator
Moderator
1,338 Views
Registered: ‎04-24-2017

Hi @ziladdev,

 

Which version of petalinux are you using?

 

 

In 2018.x petalinux/yocto rocko release it is shipped with opencv 3.3 http://cgit.openembedded.org/meta-openembedded/tree/meta-oe/recipes-support/opencv/opencv_3.3.bb?h=rocko

 

You can't use 2.4 as suggested by @shabbirk it is blacklisted from Yocto community http://layers.openembedded.org/layerindex/recipe/54289/ 

Thanks,
Sandeep
PetaLinux Yocto | Embedded SW Support

---------------------------------------------------------------------------
Don’t forget to Reply, Kudo, and Accept as Solution.
---------------------------------------------------------------------------

View solution in original post

Highlighted
Adventurer
Adventurer
1,099 Views
Registered: ‎08-16-2017

Yes, in the end we moved on to 3.1. It was indeed that the recipe was blacklisted.

0 Kudos