UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor mac_linx
Visitor
2,368 Views
Registered: ‎04-04-2017

PikeOS running on Zynq board

Hi there!

 

I'm using a custom board based on ZC702 Evaluation board and I have 2 Ethernet Interfaces: GEM0 and GEM1.

The first one is just for debug purpose and the second is used as a PHYLESS Interface to a Broadcom Switch.

Through the GEM1 Interface is possible to configure the Switch and monitor the System. To do this, I have a

loadable Ethernet Driver that uses the "llfifo" lib under Petalinux. This Environment is working well without problems.

 Now I have to port this System to a hypervisor System based on PikeOS.  PikeOS provides a multi-channel Ethernet

driver which allows to use the XEMACPS Ethernet controller from different applications simultaneously.

 

Unfortunately the driver “Ethernet XemacPS”  is dedicated to the Gigabit Ethernet interface located on the

Processor(GEM0 on PS) side from the board and is dedicated only for debug purposes. The question is, how to

redirect this drive to the Ethernet interface connected to the AXI, i.e., FPGA side(GEM! on PL) of the board? How

could I do this? I didn't find any example on the Xilinx page.

 

 

Thanks for your help on this!

Tags (1)
0 Kudos