cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Newbie
Newbie
238 Views
Registered: ‎06-24-2020

Running a Zynq UltraScale+ Linux Kernel Image On Xilinx's ARM/PMU QEMU

Hi I was trying Running a Zynq UltraScale+ Linux Kernel Image On Xilinx's ARM/PMU QEMU. Got error qemu-system-aarch64: -hw-dtb: invalid option
Please help me resolve this.

0 Kudos
Reply
1 Reply
Highlighted
Adventurer
Adventurer
145 Views
Registered: ‎08-07-2014

@coldy 

Xilinx bundles a modified version of QEMU adapted to support its boards. Looks like you are trying to use the upstream/original QEMU.

See below. The first I'm executing the QEMU packaged in my distro (almost no modification from upstream) and then Xilinx's one:

 

$ which qemu-system-aarch64 
/usr/bin/qemu-system-aarch64
$ dpkg -S /usr/bin/qemu-system-aarch64
qemu-system-arm: /usr/bin/qemu-system-aarch64
$ qemu-system-aarch64 --help | grep hw-dtb
[... no output ...]
$ source /opt/Xilinx/petalinux-v2018.3-final/settings.sh 
$ which qemu-system-aarch64 
/opt/Xilinx/petalinux-v2018.3-final/tools/linux-i386/petalinux/bin/qemu-system-aarch64
$ qemu-system-aarch64 --help | grep hw-dtb
-hw-dtb file    use 'file' as device tree image

As you can see, Xilinx's QEMU supports the "-hw-dtb" option.

 

Regards,

Brasilino

 

If this is the solution, please mark it as Accepted answer and consider give Kudos.

0 Kudos
Reply