cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
yoavklein
Visitor
Visitor
155 Views
Registered: ‎11-15-2020

SDK Generation Fails

Hello!

Background:

I'm working with no internet access. I've downloaded the downloads directory from Xilinx website and have it locally.

When I run

$petalinux-build 

It runs successfully.

 

The problem:

$petalinux-build --sdk

fails due to checksum mismatch:

The source "unfs3-0.9.22.r497.tar" is somewhat different (nevermind the reasons) so the checksum of it is not the same as it is in the recipe.

The thing is, that on another machine in the organization it works. So I tried to find the delta, and took a look at the recipe:

${peatlinux_home}/components/yocto/source/aarch64/layers/core/meta/recipes-devtool/unfs3/unfs3_0.9.22.r497.bb

I've noticed that on that other machine, someone changed the checksum string. So I tried to the same on my machine,

but it doesn't seem to work.

Questions:

1. Are there recipes that run only when --sdk is given? Where is it configured?

From what I understand, the order of execution is as follows:

a. layers.conf is consulted to see which layers are to be built.

b. In each layer - layer.conf is consulted to see what recipes there are to be built. In the layer.conf file there's the string:

BB_FILES += "${LAYERDIR}/recipes-*/*/*.bb" - So all the .bb files are included. Is my understanding correct?

2. Where do petalinux/Yocto/BitBake reads the checksum to match against the file's actual checksum? The recipe?

So why didn't it work when I manually placed the actual checksum of the file in there?

 

0 Kudos
0 Replies