cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
troykay
Visitor
Visitor
127 Views
Registered: ‎11-19-2019

Sourcing Petalinux 2019.2 settings.sh on Ubuntu 18.04.1 error: environment: line 301: ((: 10#29b: value too great for base (error token is "10#29b")

This seems to be an [occasionally] common enough question, but I can't find an answer that fixes the annoyance.

I'm getting an error when sourcing the Petalinux 2019.2 settings.sh file:

tkay@ub180401:~$ source /opt/Xilinx/Petalinux/2019.2/settings.sh
PetaLinux environment set to '/opt/Xilinx/Petalinux/2019.2'
INFO: Checking free disk space
INFO: Checking installed tools
environment: line 301: ((: 10#29b: value too great for base (error token is "10#29b")
environment: line 305: ((: 10#29b: value too great for base (error token is "10#29b")
INFO: Checking installed development libraries
INFO: Checking network and other services
WARNING: No tftp server found - please refer to "PetaLinux SDK Installation Guide" for its impact and solution

I'm running a supported release of Ubuntu (18.04.1) for PetaLinux 2019.2:

tkay@ub180401:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.1 LTS
Release: 18.04
Codename: bionic

The default shell is bash.  I've reconfigured dash to make sure it was set to 'no':

tkay@ub180401:~$ ls -altr /bin/sh
lrwxrwxrwx 1 root root 4 Mar 11 14:10 /bin/sh -> bash

All of my locales are en_US.utf8:

tkay@ub180401:~$ cat /etc/default/locale
LANG=en_US.utf8

tkay@ub180401:~$ locale
LANG=en_US.utf8
LANGUAGE=en_US.utf8
LC_CTYPE="en_US.utf8"
LC_NUMERIC="en_US.utf8"
LC_TIME="en_US.utf8"
LC_COLLATE="en_US.utf8"
LC_MONETARY="en_US.utf8"
LC_MESSAGES="en_US.utf8"
LC_PAPER="en_US.utf8"
LC_NAME="en_US.utf8"
LC_ADDRESS="en_US.utf8"
LC_TELEPHONE="en_US.utf8"
LC_MEASUREMENT="en_US.utf8"
LC_IDENTIFICATION="en_US.utf8"
LC_ALL=en_US.utf8

It's not a file I can troubleshoot or edit:

tkay@ub180401:~$ file /opt/Xilinx/Petalinux/2019.2/tools/common/petalinux/utils/petalinux-env-check
/opt/Xilinx/Petalinux/2019.2/tools/common/petalinux/utils/petalinux-env-check: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, for GNU/Linux 2.6.32, BuildID[sha1]=77aca9945d2ed01b4c9aad29fb7a1d123ad09441, stripped

All of its libraries seem to be present and accounted for:

tkay@ub180401:~$ ldd /opt/Xilinx/Petalinux/2019.2/tools/common/petalinux/utils/petalinux-env-check
linux-vdso.so.1 (0x00007fff085fb000)
libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f5a8f3b9000)
libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f5a8efc8000)
/lib64/ld-linux-x86-64.so.2 (0x00007f5a8f5bd000)

Running the application outside the settings.sh environment shows: 

tkay@ub180401:~$ /opt/Xilinx/Petalinux/2019.2/tools/common/petalinux/utils/petalinux-env-check
INFO: Checking free disk space
INFO: Checking installed tools
tr: extra operand ‘v’
Only one string may be given when deleting without squeezing repeats.
Try 'tr --help' for more information.
tr: extra operand ‘v’
Only one string may be given when deleting without squeezing repeats.
Try 'tr --help' for more information.
ERROR: You have tools that don't meet the version requirements:

-Detected make version is less than the expected 3.81
-Detected tar version is less than the expected 1.24

INFO: Checking installed development libraries
Please install them with your operating system package manager, and try again

Neither make nor tar are less than the expected value: 

tkay@ub180401:~$ make --version
GNU Make 4.1
[snip]

tkay@ub180401:~$ tar --version
tar (GNU tar) 1.29
[snip]

 

It doesn't seem to actually affect the outcome of the script.  Thoughts?

0 Kudos
0 Replies