cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
509 Views
Registered: ‎03-04-2019

TSN IP core 2018.3 integration problem

I am trying to deploy a system with an TSN IP to a custom board with a Zynq 7020. For that I have followed the guide "TSN IP SW Guide Yocto version". It all worked fine, and it made the boot files. The problem appears when in the guide it says to copy the files to an SD card. In my design I have a QSPI that holds the u-boot and a MMC that contais the kernel. Normally I use the command program_flash for programming my device, but when I try it with the files created in Yocto_TSN the next error appears:

Downloading FSBL...
Running FSBL...
Finished running FSBL.
===== mrd->addr=0xF8000110, data=0x000FA220 =====
READ: ARM_PLL_CFG (0xF8000110) = 0x000FA220
===== mrd->addr=0xF8000100, data=0x00028008 =====
READ: ARM_PLL_CTRL (0xF8000100) = 0x00028008
===== mrd->addr=0xF8000120, data=0x1F000200 =====
READ: ARM_CLK_CTRL (0xF8000120) = 0x1F000200
===== mrd->addr=0xF8000118, data=0x001452C0 =====
READ: IO_PLL_CFG (0xF8000118) = 0x001452C0
===== mrd->addr=0xF8000108, data=0x0001E008 =====
READ: IO_PLL_CTRL (0xF8000108) = 0x0001E008
Info: Remapping 256KB of on-chip-memory RAM memory to 0xFFFC0000.
===== mrd->addr=0xF8000008, data=0x00000000 =====
===== mwr->addr=0xF8000008, data=0x0000DF0D =====
MASKWRITE: addr=0xF8000008, mask=0x0000FFFF, newData=0x0000DF0D
===== mwr->addr=0xF8000910, data=0x000001FF =====
===== mrd->addr=0xF8000004, data=0x00000000 =====
===== mwr->addr=0xF8000004, data=0x0000767B =====
MASKWRITE: addr=0xF8000004, mask=0x0000FFFF, newData=0x0000767B

Problem in running uboot Flash programming initialization failed. ERROR: Flash Operation Failed

FSBL downloads and runs, so I guess it is correct and that the problem is the u-boot

I have also tried to make a PetaLinux project (also asked in Xilinx forum).

What should be the process to port from a working 2018.1 project (Vivado and Yocto configured distribution) to a 2018.3 version?

Tags (4)
0 Kudos
0 Replies