cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
gcwang
Observer
Observer
3,329 Views
Registered: ‎07-10-2012

The Xilinx linux 3.3.0 not support driver of LogiCORE IP AXI Ethernet Lite MAC?

Hello!

We want to expand some MAC by the PL of Zynq, and we found that the Xilinx support the MAC IP named as  "LogiCORE IP AXI Ethernet Lite MAC", that is good news for us.

I want to know if the Xilinx linux 3.3.0 from http://wiki.xilinx.com/zynq-linux supporting the driver of   " LogiCORE IP AXI Ethernet Lite MAC"? It seemed  not support, but i found at ds787_axi_ethernetlite.pdf that Supported s/w driver including Standalone and Linux.

Can someone give me some suggestions? thank!

0 Kudos
2 Replies
linnj
Xilinx Employee
Xilinx Employee
3,290 Views
Registered: ‎09-10-2008

Hi,

We have not tested the emaclite driver on Zynq (ARM). It is AXI and the driver should work on ARM, but til it's tested it's not working.

Thanks.
0 Kudos
gcwang
Observer
Observer
3,286 Views
Registered: ‎07-10-2012

I had modify the driver and it can work.
0 Kudos