cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
JM_Park
Participant
Participant
397 Views
Registered: ‎05-17-2020

The peekpoke app stopped

Jump to solution

Hello.

When I ran the peekpoke Application in ZCU102 with Petalinux 2018.3, the app stopped.

Here is a picture about this problem.

unnamed.png

I already ran my FPGA configuration to read and write on BRAM when ZCU102 boots.

Anybody knows how to solve this problem??

0 Kudos
1 Solution

Accepted Solutions
watari
Teacher
Teacher
357 Views
Registered: ‎06-16-2013

Hi @JM_Park 

 

Because there is not proper module as address is 0xa0001000 in your design, the app stops.

Would you make sure module in dtb and your board design by Vivado ?

 

Best regards,

View solution in original post

0 Kudos
4 Replies
watari
Teacher
Teacher
381 Views
Registered: ‎06-16-2013

Hi @JM_Park 

 

Would you share the following result to investigate the route cause ?

 

ls /sys/devices/platform/amba_pl@0/

 

Best regards,

0 Kudos
JM_Park
Participant
Participant
367 Views
Registered: ‎05-17-2020

Thank you for your reply.

Here is the result,

 

unnamed (1).png

0 Kudos
watari
Teacher
Teacher
358 Views
Registered: ‎06-16-2013

Hi @JM_Park 

 

Because there is not proper module as address is 0xa0001000 in your design, the app stops.

Would you make sure module in dtb and your board design by Vivado ?

 

Best regards,

View solution in original post

0 Kudos
JM_Park
Participant
Participant
348 Views
Registered: ‎05-17-2020

Umm... I see..

You mean.. For running this app, must have module to access memory?

Then.. Sorry but, Would you please give me some information about creating/applying module or similar things..?

0 Kudos