UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor huojianyu
Visitor
157 Views
Registered: ‎09-08-2019

Too many ttys

Jump to solution

Hi, 

I'm working on a custom board with ZU5EV.  I used petalinux to create kernel along with ubuntu file system. When booting up, I find that there are more than 300 /dev/tty*.

My question is how can I reduce the number of ttys?

image.png

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
Moderator
Moderator
114 Views
Registered: ‎12-04-2016

Re: Too many ttys

Jump to solution

Hi @huojianyu 

You may try disabling these flags from menuconfig-> Device Drivers > Character devices

CONFIG_LEGACY_PTYS=y
CONFIG_LEGACY_PTY_COUNT=256



Best Regards

Shabbir

2 Replies
Moderator
Moderator
115 Views
Registered: ‎12-04-2016

Re: Too many ttys

Jump to solution

Hi @huojianyu 

You may try disabling these flags from menuconfig-> Device Drivers > Character devices

CONFIG_LEGACY_PTYS=y
CONFIG_LEGACY_PTY_COUNT=256



Best Regards

Shabbir

Visitor huojianyu
Visitor
55 Views
Registered: ‎09-08-2019

Re: Too many ttys

Jump to solution

Hi shabbirk,

Sorry for my late reply.

I set CONFIG_LEGACY_PTY_COUNT to 5 and the number of ttys decrease to about 100. Then I tried to disable CONFIG_VT(virtual terminal) and the number decrease to less than 10.

BTW, the option in yocto is `Device Drivers -> Character Devices -> Virtual Terminal` and `Device Drivers -> Character Devices -> Maximum number of legacy PTY in use`

0 Kudos