cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
mb1000
Visitor
Visitor
426 Views
Registered: ‎01-12-2018

Trying to make petalinux flash partitions read-only

I need to make some of the QSPI flash partitions in a petalinux build read only.  In the Flash Settings configuration menu there is a place to add flash partition flags and the help says that the only supported option is 'read-only'.  This is exactly what I need but it does not seem to do anything.  I have tried adding the option (with and without quotes etc) but I cannot see any difference in the resulting image.  I can see that the option does get set in the 'config' file but nothing seems to filter through to the device tree file, if that's where it is supposed to end up.  On testing the images I find that the partitions are still writeable.

 

I have tried adding a section to system-user.dtsi to force the read-only option into the device tree as follows.  I can see that this finds its way into the build device tree file.  When I test the image from this build the partitions are definitely read-only and using flash_erase and flashcp commands on them returns the expected error message.

 

Is there something I am missing to get the read-only option in petalinux-config to work?

 

&amba {

               spi@e000d000 {

                              flash@0 {

                                             partition@0x00000000 {

                                                                           read-only;

                                             };

                                             partition@0x00480000 {

                                                                           read-only;

                                             };

                                             partition@0x00500000 {

                                                                           read-only;

                                             };

                                             partition@0x00900000 {

                                                                           read-only;

                                             };

                              };

               };

};

0 Kudos
0 Replies