cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
bfung_2
Adventurer
Adventurer
239 Views
Registered: ‎07-02-2020

U-boot Compile Hangs After Enabling BOOT_COUNT_LIMIT

I'm trying to enable boot counting so I can use altbootcmd for a fall-back boot mechanism.

I'm configuring u-boot with petalinux:

petalinux-config -c u-boot

I enable boot counting and set limit:

+ Enable support for checking boot count limit

(3) Maximum number of reboot cycles allowed

I then save, exit and do a petalinux-build -c u-boot

The build will then hang at this stage and I can see my RAM start filling up:

Initialising tasks: 100% |#######################################| Time: 0:00:02
Checking sstate mirror object availability: 100% |###############| Time: 0:00:01
Sstate summary: Wanted 135 Found 16 Missed 119 Current 870 (11% match, 88% complete)
NOTE: Executing Tasks
NOTE: Setscene tasks completed
NOTE: u-boot-xlnx: compiling from external source tree /petalinux/project/components/yocto/workspace/sources/u-boot-xlnx

 

 

 

0 Kudos
1 Reply
aravindb
Moderator
Moderator
115 Views
Registered: ‎02-07-2018

Hi @bfung_2 

Can you please follow below steps & try , It should work.

petalinux-config -c u-boot

[*] Enable support for checking boot count limit  --->
(3)   Maximum number of reboot cycles allowed
(0x4000) RAM address used for reading and writing the boot counter

Note: set the RAM address accordingly

 

Thanks & regards

Aravind

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
-------------------------------------------------------------------------------------------

0 Kudos