UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Participant kayas257
Participant
511 Views
Registered: ‎06-03-2018

U-boot bootcount_limit driver

Jump to solution

Hello,

I would like know how to enable bootcount_limit driver in uboot using Petalinux tool for xilinx zynqmp devices.

Your help will be appreciated.

 

Thanks & Regards,

Kayas Ahmed

Tags (3)
0 Kudos
1 Solution

Accepted Solutions
Participant kayas257
Participant
358 Views
Registered: ‎06-03-2018

Re: U-boot bootcount_limit driver

Jump to solution

Hello,

I have solved the problem by also defining #define CONFIG_BOOTCOUNT_ENV in platform.h

 

Thanks & Regards,

Kayas

View solution in original post

3 Replies
Moderator
Moderator
393 Views
Registered: ‎02-07-2018

Re: U-boot bootcount_limit driver

Jump to solution

HI @kayas257 

Please enable below config in platform-top.h file & build , hope it should work.

vim "project-spec/meta-user/recipes-bsp/u-boot/files/platform-top.h"

#define CONFIG_BOOTCOUNT_LIMIT

 

Thanks & regards

Aarvind

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------

0 Kudos
Participant kayas257
Participant
378 Views
Registered: ‎06-03-2018

Re: U-boot bootcount_limit driver

Jump to solution

Hello @aravindb 

This is the error I get, if i do what you said.

autoboot.c:300: undefined reference to `bootcount_load'

 

 

Thanks & Regards

Kayas

0 Kudos
Participant kayas257
Participant
359 Views
Registered: ‎06-03-2018

Re: U-boot bootcount_limit driver

Jump to solution

Hello,

I have solved the problem by also defining #define CONFIG_BOOTCOUNT_ENV in platform.h

 

Thanks & Regards,

Kayas

View solution in original post