UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Contributor
Contributor
4,006 Views
Registered: ‎04-06-2011

U-boot building problem

Hi all

 

I have ported linux 2.6.37 kernel on ML507 board. That is running very fine. next i want to use u-boot as bootloader. 

 

I have downloaded latest u-boot that has ML507 support from Xilinx Open Source Wiki and  i am using ELDK 4.1  cross compiler to build U-boot image . my commands are as follow

make ml507_config

make

 

but I think make utility is not starting the biuld process giving error like

 

invalid option

 

Should i need some modification regarding make utilty or the compiler version and source code for u-boot are not comfortable to each other.

Can any one tell the exact process.

 

thanks and regards 

0 Kudos
4 Replies
Visitor bleinweber
Visitor
3,998 Views
Registered: ‎07-06-2011

Re: U-boot building problem

That is kind of strange.  Using the ELDK 4.2 cross compiler that is linked to on this Xilinx Linux wiki page I've had no problems compiling it with the instructions provided on the U-Boot page there.  Perhaps the 4.1 tools won't work with the U-Boot version there.

 

Also, another step that I had missed is that you need to copy the xparameters.h file from your project into <u-boot>/board/xilinx/ml507/ directory.  I'm using the ML405, so it may not apply to you, but there were some options missing in my the xparameters.h file that I needed to copy from the original xparameters.h in the folder there, so keep a backup of that file.

 

U-Boot is booting on my system just fine.  I do have other problems however...

0 Kudos
Xilinx Employee
Xilinx Employee
3,977 Views
Registered: ‎07-29-2011

Re: U-boot building problem

I tried building uboot with ELDK4.1 , It compiles without any issues.

 

Regards

Madhubala

0 Kudos
Contributor
Contributor
3,975 Views
Registered: ‎04-06-2011

Re: U-boot building problem

Hi Madhbala

 

I have tried for that bt cant so can u give me your exeact steps and is there any cross compiler path setting taht i have to do

0 Kudos
Xilinx Employee
Xilinx Employee
3,964 Views
Registered: ‎07-29-2011

Re: U-boot building problem

The steps are the same as mentioned in the Xilinx wiki page ,

 

You need to set the paths (PATH)of your compiler directory and also set CROSS_COMPILER name and ARCH in your environment.

ARCH=powerpc CROSS_COMPILE=ppc_4xx-

 

Example if you have csh shell , then

setenv PATH /home/madhu/tools/eldk/4.1/usr/bin:${PATH}

setenv CROSS_COMPILE ppc_44x-

setenv ARCH powerpc

 

Hope that answers

 

 

0 Kudos