cancel
Showing results for 
Search instead for 
Did you mean: 
Adventurer
Adventurer
8,157 Views
Registered: ‎04-07-2015

USB Mouse not mount

Jump to solution

Hi,

 

I just finished to build all files for boot Linux (Linaro) on my Zedboard. When Linaro is booting up the USB mouse is not mount. I have this message :

ALSA device list:
  #0: HDMI monitor
  #1: ZED ADAU1761
EXT4-fs (mmcblk0p2): warning: mounting fs with errors, running e2fsck is recommended
EXT4-fs (mmcblk0p2): Errors on filesystem, clearing orphan list.
EXT4-fs (mmcblk0p2): recovery complete
EXT4-fs (mmcblk0p2): mounted filesystem with ordered data mode. Opts: (null)
VFS: Mounted root (ext4 filesystem) on device 179:2.

I should have :

 

ALSA device list:
  #0: HDMI monitor
  #1: ZED ADAU1761
input: DELL DELL USB Laser Mouse as /devices/amba.1/e0002000.usb/zynq-ehci.0/usb1/1-1/1-1:1.0/input/input0
hid-generic 0003:046D:C063.0001: input,hidraw0: USB HID v1.10 Mouse [DELL DELL USB Laser Mouse] on usb-zynq-ehci.0-1/input0
random: nonblocking pool is initialized
EXT4-fs (mmcblk0p2): 2 orphan inodes deleted
EXT4-fs (mmcblk0p2): recovery complete
EXT4-fs (mmcblk0p2): mounted filesystem with ordered data mode. Opts: (null)
VFS: Mounted root (ext4 filesystem) on device 179:2.

 

 

Thanks

Jo

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Adventurer
Adventurer
14,917 Views
Registered: ‎04-07-2015

Re: USB Mouse not mount

Jump to solution

Problem solved.
In the .dts file I added : dr_mode="host" (in the USB node) in order to put the USB in host mode.
Jo

View solution in original post

0 Kudos
3 Replies
Highlighted
Adventurer
Adventurer
14,918 Views
Registered: ‎04-07-2015

Re: USB Mouse not mount

Jump to solution

Problem solved.
In the .dts file I added : dr_mode="host" (in the USB node) in order to put the USB in host mode.
Jo

View solution in original post

0 Kudos
Highlighted
Adventurer
Adventurer
8,064 Views
Registered: ‎08-05-2012

Re: USB Mouse not mount

Jump to solution

Hello, I am trying to get Xilinx (specifically, either Michal Simek or Lars Clausen) to clarify the Zynq USB problem I just noticed today.  As jordanairbusds remarked USB devices suddenly stopped enumerating on my Zedboard after picking up the recent ADI kernel (https://github.com/analogdevicesinc/linux.git, xcomm_zynq branch).  Last year, I figured out how USB worked on Zedboard using the ADI 3.15 kernel and documented it in my blog (http://henryomd.blogspot.com/2014/11/understanding-linux-serial-device.html).  After isolating the USB breakage today to the kernel version change (it is now apparently at 3.19), I diffed the 2 trees and realized that the USB related files documented in Xilinx driver page USB section (http://www.wiki.xilinx.com/Linux+Drivers) are MISSING in the kernel I downloaded from ADI (through Buildroot)--except the mainlined files.  These missing files are what enables USB on Zedboard, the last time I looked into it in my blog.

 

I am not sure whether the xcomm_zynq is still the correct branch to use to pick up zynq specific files that are NOT yet mainlined, or whether there is something missing in the DTS file, as jordanairbusds suggests above.  I want to stick with the recommended method, whether it is just to stay in the zynq specific repository, or pick up the proper fix in the mainline kernel.  Can someone (Lars or Michal) from Xilinx please comment?

0 Kudos
Highlighted
Adventurer
Adventurer
8,055 Views
Registered: ‎08-05-2012

Re: USB Mouse not mount

Jump to solution
Actually, it occurred to me that since I am talking about the ADI kernel (even those the HW is the Xilinx USB transceivers), I should perhaps post this question to ADI engineer zone...
0 Kudos