cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
olebon
Observer
Observer
465 Views
Registered: ‎05-10-2019

Ubuntu on Ultrazed: Ethernet disappears

I installed Ubbuntu 16.0 on Ultrazed EG exactly as described in https://github.com/k0nze/ultrazed_boot_linux . U-BOOT can see the Ethernet port and gets an address:

Board: Xilinx ZynqMP
Bootmode: SD_MODE1
Reset reason: EXTERNAL
Net: ZYNQ GEM: ff0e0000, phyaddr 9, interface rgmii-id
eth0: ethernet@ff0e0000
U-BOOT for konz2

ethernet@ff0e0000 Waiting for PHY auto negotiation to complete........ done
BOOTP broadcast 1
...
BOOTP broadcast 5
DHCP client bound to address 172.16.20.39 (3755 ms)

However, when Ubuntu is loaded the Ethernet port disappears:

zynqmp@ultrazed:~$ sudo ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:1888 errors:0 dropped:0 overruns:0 frame:0
TX packets:1888 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:140184 (140.1 KB) TX bytes:140184 (140.1 KB)

zynqmp@ultrazed:~$

I've added full log as attachment. If anybody can help please reply Thanks

 

0 Kudos
4 Replies
shabbirk
Moderator
Moderator
422 Views
Registered: ‎12-04-2016

Hi @olebon 

It looks that you dont have PHY information in the project. Try adding it in

project-spec/meta-user/recipes-bsp/device-tree/files/system-user.dtsi 

&gem3 {
	status = "okay";
	local-mac-address = [00 0a 35 00 02 90];
	phy-mode = "rgmii-id";
	phy-handle = <&phy0>;
	phy0: phy@5 {
		reg = <0x5>;
		ti,rx-internal-delay = <0x5>;
		ti,tx-internal-delay = <0x5>;
		ti,fifo-depth = <0x1>;
	};
};
 
Best Regards
Shabbir
0 Kudos
olebon
Observer
Observer
397 Views
Registered: ‎05-10-2019

Shabbir, thank you for the advice. I had similar settings in the device tree that were generated automatically based on BSP. The only difference was that gem3 block referred to phy@9 and correspondingly it was reg=<0x9>. After per your suggestion I changed 9->5 even U-BOOT stopped recognizing eth0:

 

Net: ZYNQ GEM: ff0e0000, phyaddr 5, interface rgmii-id
Could not get PHY for eth0: addr 5
eth-1: ethernet@ff0e0000
U-BOOT for uz3eg-iocc-2019-2

ZYNQ GEM: ff0e0000, phyaddr 5, interface rgmii-id
mdio_register: non unique device name 'eth0'
ZYNQ GEM: ff0e0000, phyaddr 5, interface rgmii-id
mdio_register: non unique device name 'eth0'
ZYNQ GEM: ff0e0000, phyaddr 5, interface rgmii-id
mdio_register: non unique device name 'eth0'
ZYNQ GEM: ff0e0000, phyaddr 5, interface rgmii-id
mdio_register: non unique device name 'eth0'
No ethernet found.
ZYNQ GEM: ff0e0000, phyaddr 5, interface rgmii-id
mdio_register: non unique device name 'eth0'

 

The full text of my old (before 9->5 change) system-user.dtsi is attached.

0 Kudos
shabbirk
Moderator
Moderator
362 Views
Registered: ‎12-04-2016

Hi @olebon 

Are you able to see the eth interface in Linux, if not in uboot? For the exact PHY address, you can run mii info command from uboot.

Also, please check PHY is enabled in kernel config (Device drivers->network device support->PHY device support and infrastructure->

 

Best Regards

Shabbir

0 Kudos
olebon
Observer
Observer
352 Views
Registered: ‎05-10-2019

I have three old SOMs used in some design for a while and a new carrier that I just received. I spent some time testing them yesterday and found none of them has functional eth0. I used the SD image from Avnet's demo. I suspect that some control pins are damaged.

However, when I plugged a USB-Ethernet adapter in the USB port, something changed and the eth0 was finally up. The adapter did not work itself, but somehow helped Linux to discover its own eth0. I left USB-ETH plugged in and continued with the cable plugged in the carrier, it worked perfectly.

0 Kudos