UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor dimatodor
Visitor
548 Views
Registered: ‎09-05-2018

Unable to Detect JEDEC ID of SPI Slave

Hardware: Enclustra Mercury+ XU1 (Built around Xilinx's Zynq Ultrascale+™ MPSoC)

I am trying to add spi node entry in DTS file (zynqmp-enclustra-xu1.dts):

 

Add Pin Mux in pinctrl_spi0_default

 

pinctrl_spi0_default: spi0-default {
mux {
groups = "spi0_0_grp";
function = "spi0";
};

conf {
groups = "spi0_0_grp";
bias-disable;
slew-rate = <SLEW_RATE_SLOW>;
io-standard = <IO_STANDARD_LVCMOS18>;
};

mux-cs {
groups = "spi0_0_ss0_grp", "spi0_0_ss1_grp",
"spi0_0_ss2_grp";
function = "spi0_ss";
};

conf-cs {
groups = "spi0_0_ss0_grp", "spi0_0_ss1_grp",
"spi0_0_ss2_grp";
bias-disable;
};
};

 

 

&spi0 {
status = "okay";
num-cs = <1>;
pinctrl-names = "default";
pinctrl-0 = <&pinctrl_spi0_default>;
spi0_flash0: flash@0 {
#address-cells = <1>;
#size-cells = <1>;
compatible = "sst,sst25wf080", "jedec,spi-nor";
spi-max-frequency = <50000000>;
reg = <0>;
partition@0 {
label = "data";
reg = <0x0 0x100000>;
};
};
};

 

When i try to boot kernel then get following error:

 

# dmesg | grep spi
[ 2.273824] m25p80 spi0.0: unrecognized JEDEC id bytes: ff, ff, ff

 

Please help...

 

0 Kudos
3 Replies
Moderator
Moderator
528 Views
Registered: ‎09-12-2007

Re: Unable to Detect JEDEC ID of SPI Slave

Can you share the defconfig for this board? Can you share the the dtb too?

Also, the hdf to see the config in pcw.
0 Kudos
Visitor dimatodor
Visitor
500 Views
Registered: ‎09-05-2018

Re: Unable to Detect JEDEC ID of SPI Slave

Hi. Thank you for your attention to the topic.

These are my kernel configuration files and dts-file:

0 Kudos
Moderator
Moderator
485 Views
Registered: ‎09-12-2007

Re: Unable to Detect JEDEC ID of SPI Slave

Ok, the dts (I only checked the spi node) looks fine based on the settings in the PCW. You have a 50Mhz clk, so 50 / 6 will be the clock used. 

 

I think the issue is the defconfig. I can see a few missing configs. For example:

 

CONFIG_SPL_SPI_FLASH_SUPPORT=y
CONFIG_SPL_SPI_SUPPORT=y
CONFIG_ZYNQMP_QSPI=y

CONFIG_DM_SPI_FLASH=y
CONFIG_SPI_FLASH=y
CONFIG_SPI_FLASH_BAR=y
CONFIG_SPI_FLASH_ISSI=y
CONFIG_SPI_FLASH_MACRONIX=y
CONFIG_SPI_FLASH_SPANSION=y
CONFIG_SPI_FLASH_STMICRO=y
CONFIG_SPI_FLASH_WINBOND=y

 

You should compare this with a the zcu102 defconfig to see what is missing.

 

For debugging, you could enable the debug in the uboot:

https://github.com/Xilinx/u-boot-xlnx/blob/master/drivers/spi/Makefile

 

ccflags-y = -DDEBUG

 

Recompile and reboot and do a sf probe again to see the debug messages to get a better idea 

of where exactly this is failing.

0 Kudos