UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Observer rendres
Observer
11,669 Views
Registered: ‎03-13-2017

Unable to mount root fs on unknown-block(0,0)

Jump to solution

 

Hello guys,

 

I'm trying to create an app to control a webcam connected to the USB connection of the Zedboard, pass it through the HP of the ARM to the VDMAs and use the images taken in the PL part. The steps that I follow to create my app are these:

 

  1. Create the app (Zynq template), get my hw description using the bitstream config project to boot from SD.
  2. Config kernel to recognize USB webcam.
  3. Config Rootfs to add to the project -> libusb1, opencv, ffmpeg in the libs section.
  4. Create an app where I load my main code. In this part I use a CMakeLists.txt to create an executable of the app using directories and libraries of the petaLinux project.
  5. Create another app with the install template. I use my executable built in step 4. Build the app.
  6. Use petalinux-build and petalinux-package.
  7. Copy BOOT.bin and image.ub to the SD.
  8. Get this error.

 

U-Boot 2016.07 (Mar 10 2017 - 14:18:51 +0100)

DRAM:  ECC disabled 512 MiB
MMC:   sdhci@e0100000: 0
SF: Detected S25FL256S_64K with page size 256 Bytes, erase size 64 KiB, total 32 MiB
*** Warning - bad CRC, using default environment

## Error: flags type check failure for "serverip" <= "AUTO" (type: i)
himport_r: can't insert "serverip=AUTO" into hash table
In:    serial
Out:   serial
Err:   serial
Net:   ZYNQ GEM: e000b000, phyaddr -1, interface rgmii-id
eth0: ethernet@e000b000
U-BOOT for

Hit any key to stop autoboot:  0 
Device: sdhci@e0100000
Manufacturer ID: 58
OEM: 4444
Name: DDINC 
Tran Speed: 50000000
Rd Block Len: 512
SD version 3.0
High Capacity: Yes
Capacity: 3.7 GiB
Bus Width: 4-bit
Erase Group Size: 512 Bytes
reading image.ub
99780656 bytes read in 8416 ms (11.3 MiB/s)
## Loading kernel from FIT Image at 10000000 ...
   Using 'conf@1' configuration
   Verifying Hash Integrity ... OK
   Trying 'kernel@0' kernel subimage
     Description:  Linux Kernel
     Type:         Kernel Image
     Compression:  uncompressed
     Data Start:   0x100000d4
     Data Size:    3888872 Bytes = 3.7 MiB
     Architecture: ARM
     OS:           Linux
     Load Address: 0x00008000
     Entry Point:  0x00008000
     Hash algo:    sha1
     Hash value:   0d6e64ee33757c88c3dcea6268afb10d5f6327e1
   Verifying Hash Integrity ... sha1+ OK
## Loading ramdisk from FIT Image at 10000000 ...
   Using 'conf@1' configuration
   Trying 'ramdisk@0' ramdisk subimage
     Description:  ramdisk
     Type:         RAMDisk Image
     Compression:  uncompressed
     Data Start:   0x103b9854
     Data Size:    95874026 Bytes = 91.4 MiB
     Architecture: ARM
     OS:           Linux
     Load Address: unavailable
     Entry Point:  unavailable
     Hash algo:    sha1
     Hash value:   869fbb0773a9a4e5dd6caa43ca5136ea5b7f431d
   Verifying Hash Integrity ... sha1+ OK
## Loading fdt from FIT Image at 10000000 ...
   Using 'conf@1' configuration
   Trying 'fdt@0' fdt subimage
     Description:  Flattened Device Tree blob
     Type:         Flat Device Tree
     Compression:  uncompressed
     Data Start:   0x103b58b0
     Data Size:    16114 Bytes = 15.7 KiB
     Architecture: ARM
     Hash algo:    sha1
     Hash value:   d370e4f0ff3e4139b4a77405193156a49504aa47
   Verifying Hash Integrity ... sha1+ OK
   Booting using the fdt blob at 0x103b58b0
   Loading Kernel Image ... OK
   Loading Ramdisk to 02491000, end 07fffbea ... OK
   Loading Device Tree to 0248a000, end 02490ef1 ... OK

Starting kernel ...

Uncompressing Linux... done, booting the kernel.
Booting Linux on physical CPU 0x0
Linux version 4.6.0-xilinx (rene@rene) (gcc version 5.2.1 20151005 (Linaro GCC 5.2-2015.11-2) ) #1 SMP PR7
CPU: ARMv7 Processor [413fc090] revision 0 (ARMv7), cr=18c5387d
CPU: PIPT / VIPT nonaliasing data cache, VIPT aliasing instruction cache
Machine model: webCam
bootconsole [earlycon0] enabled
cma: Reserved 16 MiB at 0x1f000000
Memory policy: Data cache writealloc
percpu: Embedded 12 pages/cpu @debcb000 s19776 r8192 d21184 u49152
Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 130048
Kernel command line: console=ttyPS0,115200 earlyprintk
PID hash table entries: 2048 (order: 1, 8192 bytes)
Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
Memory: 399856K/524288K available (5288K kernel code, 240K rwdata, 1880K rodata, 1024K init, 222K bss, 10)
Virtual kernel memory layout:
    vector  : 0xffff0000 - 0xffff1000   (   4 kB)
    fixmap  : 0xffc00000 - 0xfff00000   (3072 kB)
    vmalloc : 0xe0800000 - 0xff800000   ( 496 MB)
    lowmem  : 0xc0000000 - 0xe0000000   ( 512 MB)
    pkmap   : 0xbfe00000 - 0xc0000000   (   2 MB)
    modules : 0xbf000000 - 0xbfe00000   (  14 MB)
      .text : 0xc0008000 - 0xc0800340   (8161 kB)
      .init : 0xc0900000 - 0xc0a00000   (1024 kB)
      .data : 0xc0a00000 - 0xc0a3c1a0   ( 241 kB)
       .bss : 0xc0a3c1a0 - 0xc0a73a64   ( 223 kB)
Preemptible hierarchical RCU implementation.
        Build-time adjustment of leaf fanout to 32.
        RCU restricting CPUs from NR_CPUS=4 to nr_cpu_ids=2.
RCU: Adjusting geometry for rcu_fanout_leaf=32, nr_cpu_ids=2
NR_IRQS:16 nr_irqs:16 16
efuse mapped to e0800000
slcr mapped to e0802000
L2C: platform modifies aux control register: 0x72360000 -> 0x72760000
L2C: DT/platform modifies aux control register: 0x72360000 -> 0x72760000
L2C-310 erratum 769419 enabled
L2C-310 enabling early BRESP for Cortex-A9
L2C-310 full line of zeros enabled for Cortex-A9
L2C-310 ID prefetch enabled, offset 1 lines
L2C-310 dynamic clock gating enabled, standby mode enabled
L2C-310 cache controller enabled, 8 ways, 512 kB
L2C-310: CACHE_ID 0x410000c8, AUX_CTRL 0x76760001
zynq_clock_init: clkc starts at e0802100
Zynq clock init
sched_clock: 64 bits at 333MHz, resolution 3ns, wraps every 4398046511103ns
clocksource: arm_global_timer: mask: 0xffffffffffffffff max_cycles: 0x4ce07af025, max_idle_ns: 4407952090s
Switching to timer-based delay loop, resolution 3ns
clocksource: ttc_clocksource: mask: 0xffff max_cycles: 0xffff, max_idle_ns: 537538477 ns
timer #0 at e080a000, irq=17
Console: colour dummy device 80x30
Calibrating delay loop (skipped), value calculated using timer frequency.. 666.66 BogoMIPS (lpj=3333333)
pid_max: default: 32768 minimum: 301
Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
CPU: Testing write buffer coherency: ok
CPU0: thread -1, cpu 0, socket 0, mpidr 80000000
Setting up static identity map for 0x100000 - 0x100058
CPU1: thread -1, cpu 1, socket 0, mpidr 80000001
Brought up 2 CPUs
SMP: Total of 2 processors activated (1333.33 BogoMIPS).
CPU: All CPU(s) started in SVC mode.
devtmpfs: initialized
VFP support v0.3: implementor 41 architecture 3 part 30 variant 9 rev 4
clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
pinctrl core: initialized pinctrl subsystem
NET: Registered protocol family 16
DMA: preallocated 256 KiB pool for atomic coherent allocations
cpuidle: using governor menu
hw-breakpoint: found 5 (+1 reserved) breakpoint and 1 watchpoint registers.
hw-breakpoint: maximum watchpoint size is 4 bytes.
zynq-ocm f800c000.ocmc: ZYNQ OCM pool: 256 KiB @ 0xe0880000
zynq-pinctrl 700.pinctrl: zynq pinctrl initialized
vgaarb: loaded
SCSI subsystem initialized
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
media: Linux media interface: v0.10
Linux video capture interface: v2.00
pps_core: LinuxPPS API ver. 1 registered
pps_core: Software ver. 5.3.6 - Copyright 2005-2007 Rodolfo Giometti <giometti@linux.it>
PTP clock support registered
EDAC MC: Ver: 3.0.0
Advanced Linux Sound Architecture Driver Initialized.
clocksource: Switched to clocksource arm_global_timer
NET: Registered protocol family 2
TCP established hash table entries: 4096 (order: 2, 16384 bytes)
TCP bind hash table entries: 4096 (order: 3, 32768 bytes)
TCP: Hash tables configured (established 4096 bind 4096)
UDP hash table entries: 256 (order: 1, 8192 bytes)
UDP-Lite hash table entries: 256 (order: 1, 8192 bytes)
NET: Registered protocol family 1
RPC: Registered named UNIX socket transport module.
RPC: Registered udp transport module.
RPC: Registered tcp transport module.
RPC: Registered tcp NFSv4.1 backchannel transport module.
Trying to unpack rootfs image as initramfs...
rootfs image is not initramfs (write error); looks like an initrd
/initrd.image: incomplete write (-28 != 95874026)
Freeing initrd memory: 93628K (c2491000 - c8000000)
hw perfevents: enabled with armv7_cortex_a9 PMU driver, 7 counters available
futex hash table entries: 512 (order: 3, 32768 bytes)
workingset: timestamp_bits=28 max_order=17 bucket_order=0
jffs2: version 2.2. (NAND) (SUMMARY)  © 2001-2006 Red Hat, Inc.
io scheduler noop registered
io scheduler deadline registered
io scheduler cfq registered (default)
dma-pl330 f8003000.dmac: Loaded driver for PL330 DMAC-241330
dma-pl330 f8003000.dmac:        DBUFF-128x8bytes Num_Chans-8 Num_Peri-4 Num_Events-16
e0001000.serial: ttyPS0 at MMIO 0xe0001000 (irq = 143, base_baud = 3125000) is a xuartps
�console [ttyPS0] enabled
console [ttyPS0] enabled
bootconsole [earlycon0] disabled
bootconsole [earlycon0] disabled
xdevcfg f8007000.devcfg: ioremap 0xf8007000 to e086c000
[drm] Initialized drm 1.1.0 20060810
brd: module loaded
loop: module loaded
m25p80 spi0.0: found s25fl256s1, expected m25p80
m25p80 spi0.0: s25fl256s1 (32768 Kbytes)
4 ofpart partitions found on MTD device spi0.0
Creating 4 MTD partitions on "spi0.0":
0x000000000000-0x000000500000 : "boot"
0x000000500000-0x000000520000 : "bootenv"
0x000000520000-0x000000fa0000 : "kernel"
0x000000fa0000-0x000002000000 : "spare"
CAN device driver interface
gpiod_set_value: invalid GPIO
libphy: MACB_mii_bus: probed
macb e000b000.ethernet eth0: Cadence GEM rev 0x00020118 at 0xe000b000 irq 145 (00:0a:35:00:1e:53)
Marvell 88E1510 e000b000.etherne:00: attached PHY driver [Marvell 88E1510] (mii_bus:phy_addr=e000b000.eth)
e1000e: Intel(R) PRO/1000 Network Driver - 3.2.6-k
e1000e: Copyright(c) 1999 - 2015 Intel Corporation.
ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
ehci-pci: EHCI PCI platform driver
usbcore: registered new interface driver usb-storage
e0002000.usb supply vbus not found, using dummy regulator
ULPI transceiver vendor/product ID 0x0451/0x1507
Found TI TUSB1210 ULPI transceiver.
ULPI integrity check: passed.
ci_hdrc ci_hdrc.0: EHCI Host Controller
ci_hdrc ci_hdrc.0: new USB bus registered, assigned bus number 1
ci_hdrc ci_hdrc.0: USB 2.0 started, EHCI 1.00
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 1 port detected
udc-core: couldn't find an available UDC - added [g_ether] to list of pending drivers
mousedev: PS/2 mouse device common for all mice
i2c /dev entries driver
uvcvideo: Unable to create debugfs directory
usbcore: registered new interface driver uvcvideo
USB Video Class driver (1.1.1)
EDAC MC: ECC not enabled
Xilinx Zynq CpuIdle Driver started
sdhci: Secure Digital Host Controller Interface driver
sdhci: Copyright(c) Pierre Ossman
sdhci-pltfm: SDHCI platform and OF driver helper
mmc0: SDHCI controller on e0100000.sdhci [e0100000.sdhci] using DMA
ledtrig-cpu: registered to indicate activity on CPUs
usbcore: registered new interface driver usbhid
usbhid: USB HID core driver
NET: Registered protocol family 10
sit: IPv6 over IPv4 tunneling driver
NET: Registered protocol family 17
can: controller area network core (rev 20120528 abi 9)
NET: Registered protocol family 29
can: raw protocol (rev 20120528)
can: broadcast manager protocol (rev 20120528 t)
can: netlink gateway (rev 20130117) max_hops=1
Registering SWP/SWPB emulation handler
hctosys: unable to open rtc device (rtc0)
ALSA device list:
  No soundcards found.
mmc0: new high speed SDHC card at address 0007
mmcblk0: mmc0:0007 DDINC 3.71 GiB 
 mmcblk0: p1
RAMDISK: Couldn't find valid RAM disk image starting at 0.
VFS: Cannot open root device "(null)" or unknown-block(0,0): error -6
Please append a correct "root=" boot option; here are the available partitions:
0100           16384 ram0  (driver?)
0101           16384 ram1  (driver?)
0102           16384 ram2  (driver?)
0103           16384 ram3  (driver?)
0104           16384 ram4  (driver?)
0105           16384 ram5  (driver?)
0106           16384 ram6  (driver?)
0107           16384 ram7  (driver?)
0108           16384 ram8  (driver?)
0109           16384 ram9  (driver?)
010a           16384 ram10  (driver?)
010b           16384 ram11  (driver?)
010c           16384 ram12  (driver?)
010d           16384 ram13  (driver?)
010e           16384 ram14  (driver?)
010f           16384 ram15  (driver?)
1f00            5120 mtdblock0  (driver?)
1f01             128 mtdblock1  (driver?)
1f02           10752 mtdblock2  (driver?)
1f03           16768 mtdblock3  (driver?)
b300         3887104 mmcblk0  driver: mmcblk
  b301         3883008 mmcblk0p1 012ef25d-01
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
CPU0: stopping
CPU: 0 PID: 0 Comm: swapper/0 Not tainted 4.6.0-xilinx #1
Hardware name: Xilinx Zynq Platform
[<c010e48c>] (unwind_backtrace) from [<c010a6b0>] (show_stack+0x10/0x14)
[<c010a6b0>] (show_stack) from [<c02d3a94>] (dump_stack+0x80/0x9c)
[<c02d3a94>] (dump_stack) from [<c010cbc4>] (ipi_cpu_stop+0x3c/0x70)
[<c010cbc4>] (ipi_cpu_stop) from [<c010d440>] (handle_IPI+0x64/0x84)
[<c010d440>] (handle_IPI) from [<c0101400>] (gic_handle_irq+0x74/0x90)
[<c0101400>] (gic_handle_irq) from [<c010b094>] (__irq_svc+0x54/0x90)
Exception stack(0xc0a01f30 to 0xc0a01f78)
1f20:                                     00000000 00000001 1e28f000 debcf1c0
1f40: 00000001 debce5c0 8d8692a4 00000001 8d1a977b 00000001 00000000 00000001
1f60: 00000008 c0a01f80 c04a5720 c04a5744 60000013 ffffffff
[<c010b094>] (__irq_svc) from [<c04a5744>] (cpuidle_enter_state+0xe0/0x1b4)
[<c04a5744>] (cpuidle_enter_state) from [<c014a25c>] (cpu_startup_entry+0x184/0x1d0)
[<c014a25c>] (cpu_startup_entry) from [<c0900bbc>] (start_kernel+0x2ec/0x34c)
[<c0900bbc>] (start_kernel) from [<0000807c>] (0x807c)
---[ end Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

I can find in my pnlx system the USB and it recognizes it as the Microsoft HD Webcam it is. plnx also creates the /dev/video*, so I assume that the problem is not an USB config one.

 

I have several questions.

  1. Can I use opencv and ffmeg loading it with petalinux tools dinamyc libraries or do I need to cross-compile with static ones?
  2. Can I use my code following the steps 4 and 5? Is there a better way to compile my code?
  3. The only thing I haven't done is to add to the bootargs the "uio_pdrv_genirq.of_id=generic-uio" because I'm using the 2016.4 version of PetaLinux and Vivado and I couldn't find the way to edit it (in this version I can't find the kernel commandline type ---> "extend bootloader kernel arguments" option).

 

 

Thanks for the help!

 

0 Kudos
1 Solution

Accepted Solutions
Observer rendres
Observer
19,668 Views
Registered: ‎03-13-2017

Re: Unable to mount root fs on unknown-block(0,0)

Jump to solution

Hello,

 

Finally solved it building a new project and configuring all again!

 

Thanks,

0 Kudos
7 Replies
Visitor vtl_m
Visitor
11,658 Views
Registered: ‎03-12-2017

Re: Unable to mount root fs on unknown-block(0,0)

Jump to solution

Looks like your ramdisk image is damaged:

 

Trying to unpack rootfs image as initramfs...
rootfs image is not initramfs (write error); looks like an initrd
/initrd.image: incomplete write (-28 != 95874026)
0 Kudos
Moderator
Moderator
11,623 Views
Registered: ‎12-04-2016

Re: Unable to mount root fs on unknown-block(0,0)

Jump to solution

Hi

 

Can you please try creating two partitions one with FAT32 boot partition of may be 200MB and other EXT4 rootfs partition with remaining space?

 

 

Best Regards

Shabbir 

0 Kudos
Observer rendres
Observer
19,669 Views
Registered: ‎03-13-2017

Re: Unable to mount root fs on unknown-block(0,0)

Jump to solution

Hello,

 

Finally solved it building a new project and configuring all again!

 

Thanks,

0 Kudos
Moderator
Moderator
11,533 Views
Registered: ‎04-17-2011

Re: Unable to mount root fs on unknown-block(0,0)

Jump to solution
@rendres, please close this thread by marking your post as an accepted solution for the benefit of the community.
Regards,
Debraj
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos
Explorer
Explorer
11,468 Views
Registered: ‎06-03-2015

Re: Unable to mount root fs on unknown-block(0,0)

Jump to solution

 

 

Please append a correct "root=" boot option; here are the available partitions:

The issue is giving the Log as above.

 

It is because, we are not providing the proper "Boot arguments" ,

for example when we are doing nfs boot  "root=/dev/nfs rw "  or  "root=/dev/ram" (for Inital ramdisk)

ans in some cases in /etc/exports  is not updated for NFS file system directory, that creates same issue.

 

Proper Boot arguments will resolve these issues.

 

Thanks & Regards
Satish.G

G Satish Kumar
0 Kudos
Observer sigwe
Observer
5,416 Views
Registered: ‎11-30-2017

Re: Unable to mount root fs on unknown-block(0,0)

Jump to solution

I am running into this exact same issue. While following this solution I am having some trouble running this command 

 

<mkimage -f fitImage.its-1.0-r0 ${plnx_project_folder}/images/linux/image.ub>

 

How must this be written in the command prompt to run successfully? I've tried the following

 

< mkimage -f fitImage.its-1.0-r0 /home/csi/Downloads/new2/build/tmp/deploy/images/plnx_arm /images/linux/image.ub > 

and I get ' No such file or directory  mkimage Can't add hashes to FIT blob

 

 

 

0 Kudos
Visitor jack_kk
Visitor
275 Views
Registered: ‎05-26-2019

Re: Unable to mount root fs on unknown-block(0,0)

Jump to solution

Can you share your project? I got tired finding solution of following error "end kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block (179,2)"

I will be very very thankful to you..

0 Kudos