cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
jessekleve
Visitor
Visitor
633 Views
Registered: ‎08-28-2018

Unable to use custom rootfs for dom0 on top of Xen

I'm have troubles getting a dom0 up and running with my custom rootfs as the ramdisk. I've tried a number of different ways. I tried an NFS mount with bootargs for dom0 set to

 

console=hvc0 earlycon=xen earlyprintk=xen rootdelay=1 root=/dev/nfs nfsroot=<ipaddr>:<serverip>:<gateway>:<netmask>::<interface>:off devtmpfs.mount=1 clk_ignore_unused

 

Another attempt was I extracted my rootfs onto partition 2 of my SD card and tried booting with

console=hvc0 earlycon=xen earlyprintk=xen root=/dev/mmcblk0p2 rw rootwait devtmpfs.mount=1 clk_ignore_unused

again, with no luck.

 

I also don't know what it's falling back to. Where is the default rootfs dom0 uses?

 

The thing I've been trying the most is adding a node in the xen device tree under chosen

 

rootfs0 {
    compatible = "multiboot,ramdisk", "multiboot-module";
    reg = <0x0 0x3180000 0x3100000>;
};

hoping that xen would point the kernel to this given bootargs as

console=hvc0 earlycon=xen rootdelay=1 root/dev/ram devtmpfs.mount=1 clk_ignore_unused

I have confirmed in each case that the kernel gets the bootargs I have mentioned here. I verified by looking in the boot logs and in /proc/cmdline. They both verify the bootargs that I expect are getting passed to the dom0 kernel.

 

All three of these instances I have sw switch 6 set to SD card boot. This is on a zcu102-zynqmp with all pre-built images I got from Dornerworks SDK along with my custom rootfs built with yocto.

 

Summary:

- Can anyone give me an avenue to explore. I'm at a loss

- What is the default rootfs that dom0 with fall back to?

Tags (1)
0 Kudos
0 Replies