cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
timo-ge
Explorer
Explorer
3,152 Views
Registered: ‎11-12-2007

Virtex5 PowerPC440 load average

Hi, I am runnign linux on a custom board based on the ML507 with the PPC440 running at 500MHz.

I recently moved from kernel 3.0.3 to kernel 3.2.17. Everthing runs just fine, but I'm wondering about the load average value. 

 

On 3.0 I had a load average of about 0.0 when doing nothing (complete idle). 

On 3.2 I have a value just above 2.0 (!). Did I missed any patch in arch/powerpc when switching to 3.2?

 

Top gives me this:

load average: 2.08, 1.90, 1.82

Tasks: 49 total, 1 running, 48 sleeping, 0 stopped, 0 zombie
Cpu(s): 1.6%us, 2.3%sy, 0.0%ni, 96.1%id, 0.0%wa, 0.0%hi, 0.0%si, 0.0%st
Mem: 56756k total, 42704k used, 14052k free, 6812k buffers
Swap: 0k total, 0k used, 0k free, 21816k cached

Did anyone notice soething similar?

 

0 Kudos
2 Replies
linnj
Xilinx Employee
Xilinx Employee
3,148 Views
Registered: ‎09-10-2008

We have not moved to 3.2 yet for PPC so I've not see anything like that yet.

Did you check the wall time (sleep command from the command line) to make sure it's right as if it's wrong maybe top is not calculating things right?

Thanks.
0 Kudos
timo-ge
Explorer
Explorer
3,142 Views
Registered: ‎11-12-2007

Hm, ok. I found out, that it must be something with my init scripts and my application. Just starting the kernel gixev me a load average of 0.00 so thats fine. 

Maybe it's something about sleep.

 

BTW, kernel 3.2.17 runs very smooth withou any issues on my board. I still use the ll_temac driver which relies on the xilinx_common drivers.

 

Thanks for your answer.

tg

0 Kudos