cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Newbie
Newbie
204 Views
Registered: ‎01-10-2018

Vitis MicroBlaze Linux FS-BOOT error

I'm having trouble deploying a Linux MicroBlaze application to a VCU118 board using Vitis. Here's the steps I've taken so far:
 
1. Created a block design in Vivado and generated BIT and XSA files for the project.
2. Generated a PetaLinux project using the XSA file and packaged the project as a download.bit file.
3. Created a platform project in Vitis using the XSA file and built it.
4. Created a Linux Hello World application project in Vitis on top of the platform project and imported the PetaLinux project sysroot files and built the project.
5. Programmed the FPGA using the download.bit file in Vitis.
6. Attempted to launch the Vitis debugger and received a "Connection refused" error in Vitis. I opened a UART console while launching the debugger and got a clue to the problem: "FS-BOOT: No existing image in FLASH. FS-BOOT: Please download the image with JTAG."
7. I tried fixing the error by using the Program Flash tool in Vitis and selecting the ELF file from the application project, but I still get the same FS-BOOT and connection refused errors.
 
Am I missing a step in the process?
0 Kudos
1 Reply
Highlighted
Moderator
Moderator
126 Views
Registered: ‎09-12-2007

If you are debugging a linux app, you need to connect between the tcf agent running on the linux image and vitis. They must be on the same LAN

0 Kudos