cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Scholar
Scholar
1,197 Views
Registered: ‎08-24-2011

Vivado/Petalinux 2017.4 - how to enable x264enc in gstreamer1.0?

Jump to solution

Hi,

 

I need to build a Petalinux image with gstreamer1.0 supporting the h264 encoding.

I have created my own layer (attached) with:

LICENSE_FLAGS_WHITELIST_append = " commercial"

added in the layer.conf and

IMAGE_INSTALL_append = " gstreamer1.0-plugins-ugly"
IMAGE_INSTALL_append = " x264"

(among others) added in the bbappend file in the recipe.

I can see, that the gstreamer1.0-plugins-ugly is compiled into my image, but without x264enc.

Checking the gstreamer1.0-plugins-ugly.inc in petalinux installation directory

( components/yocto/source/aarch64/layers/core/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly.inc )

I can see, that "x264" is not selected in

PACKAGECONFIG ??= " \
    ${GSTREAMER_ORC} \
    a52dec lame mpg123 mpeg2dec \
"

Of course I can patch it here, but I'd prefer to it on the project level, not system-wide.

How can I modify the setting of the standard package in my own layer?

 

TIA & Regards,

Wojtek

 

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Scholar
Scholar
1,404 Views
Registered: ‎08-24-2011

OK. It was my stupid mistake. It should be

PACKAGECONFIG_append_pn-gstreamer1.0-plugins-ugly = " x264"

in the layer.conf

I attach the corrected layer definition.

 

Regards,

Wojtek

View solution in original post

0 Kudos
2 Replies
Highlighted
Scholar
Scholar
1,186 Views
Registered: ‎08-24-2011

I have tried to modify the gstreamer1.0-plugins-ugle package settings using the following methods

(as described e.g., here: https://lists.yoctoproject.org/pipermail/yocto/2015-April/024461.html )

PACKAGECONFIG_pn_gstreamer1.0-plugins-ugly += "  x264"
PACKAGECONFIG_pn_gstreamer1.0-plugins-ugly_append = "  x264"
PACKAGECONFIG_pn_gstreamer1.0-plugins-ugly = "orc  x264"

I have tried to put them into the layer.conf and into the bbappend file, but none of the above worked...

 

Regards,

Wojtek

0 Kudos
Highlighted
Scholar
Scholar
1,405 Views
Registered: ‎08-24-2011

OK. It was my stupid mistake. It should be

PACKAGECONFIG_append_pn-gstreamer1.0-plugins-ugly = " x264"

in the layer.conf

I attach the corrected layer definition.

 

Regards,

Wojtek

View solution in original post

0 Kudos