cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Adventurer
Adventurer
357 Views
Registered: ‎11-02-2014

With System Overlay/ FPGA Device Manager enabled MMC's are not working.

Hi,

Petalinux 2019.1. I enabled device tree overlays, and now both MMC devices time out during boot. I have checked the generated device tree entries for the two MMC channels in use:

mmc@ff160000 {
			u-boot,dm-pre-reloc;
			compatible = "xlnx,zynqmp-8.9a", "arasan,sdhci-8.9a";
			status = "okay";
			interrupt-parent = <0x4>;
			interrupts = <0x0 0x30 0x4>;
			reg = <0x0 0xff160000 0x0 0x1000>;
			clock-names = "clk_xin", "clk_ahb";
			xlnx,device_id = <0x0>;
			#stream-id-cells = <0x1>;
			iommus = <0xd 0x870>;
			power-domains = <0xc 0x27>;
			clocks = <0x3 0x36 0x3 0x1f>;
			clock-frequency = <0x2faee8c>;
			xlnx,mio_bank = <0x0>;
			no-1-8-v;
			non-removable;
			disable-wp;
			bus-width = <0x8>;
			phandle = <0x5f>;
		};

		mmc@ff170000 {
			u-boot,dm-pre-reloc;
			compatible = "xlnx,zynqmp-8.9a", "arasan,sdhci-8.9a";
			status = "okay";
			interrupt-parent = <0x4>;
			interrupts = <0x0 0x31 0x4>;
			reg = <0x0 0xff170000 0x0 0x1000>;
			clock-names = "clk_xin", "clk_ahb";
			xlnx,device_id = <0x1>;
			#stream-id-cells = <0x1>;
			iommus = <0xd 0x871>;
			power-domains = <0xc 0x28>;
			clocks = <0x3 0x37 0x3 0x1f>;
			clock-frequency = <0x2faee8c>;
			xlnx,mio_bank = <0x1>;
			no-1-8-v;
			wp-inverted;
			phandle = <0x60>;
		};

These settings were working without device tree overlays. Any ideas where to look for the problem?

 

Thanks,

Brian

0 Kudos
1 Reply
Highlighted
Adventurer
Adventurer
317 Views
Registered: ‎11-02-2014

I just did a quick confirmation. If I have FPGA Manager enabled MMC works, if I disable it, it does not work. As far as I can tell the only differences are that in the case of FPGA Manager enabled, the FPGA is not programmed, since the .bit file is not included in BOOT.bin and the device tree is also smaller, since much is included in the PL dtbo.

As I mentioned, I checked the generated system.dtb, and the entry for MMC is correct, so I do not think the MMC is necessarily at fault.

If I specify that the bitstream should be added to BOOT.bin anyway, the tool reports that "WARNING: Fpga manager enabled, skipping bistream to pack into BOOT.BIN. I don't really understand why this should be a problem; it should not have any effect on MMC functionality?

Best,

Brian

0 Kudos