cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Adventurer
Adventurer
18,688 Views
Registered: ‎11-27-2010

Yocto build issues

Hi,

    following these steps at this link

==============================

http://www.wiki.xilinx.com/Yocto+OSL+Image+build

 

==============================

[A] is this command correct ?

 

source setupsdk

 

or it should be

 

source setup sdk ?

 

[B] what about this command ?

source pkgsetup

 

==============================

i get this error

 

ERROR: Failed to obtain CodeSourcery toolchain version: Execution of '/proj/xbuilds/2016.2_daily_latest/installs/lin64/SDK/2016.2/gnu/aarch64/lin/aarch64-linux/bin/aarch64-linux-gnu-gcc -v' failed: command not found
ERROR: Make sure that MACHINE is set correctly in your local.conf and the toolchain supports aarch64.
ERROR: Failed to obtain CodeSourcery toolchain version: Execution of '/proj/xbuilds/2016.2_daily_latest/installs/lin64/SDK/2016.2/gnu/aarch64/lin/aarch64-linux/bin/aarch64-linux-gnu-gcc -v' failed: command not found
ERROR: Make sure that MACHINE is set correctly in your local.conf and the toolchain supports aarch64.
ERROR: Failed to obtain CodeSourcery toolchain version: Execution of '/proj/xbuilds/2016.2_daily_latest/installs/lin64/SDK/2016.2/gnu/aarch64/lin/aarch64-linux/bin/aarch64-linux-gnu-gcc -v' failed: command not found
ERROR: Make sure that MACHINE is set correctly in your local.conf and the toolchain supports aarch64.
ERROR:  OE-core's config sanity checker detected a potential misconfiguration.
    Either fix the cause of this error or at your own risk disable the checker (see sanity.conf).
    Following is the list of potential problems / advisories:

    Do not use Bitbake as root.

 

=======

meanwhile, sh is on bash, all vivado tools are installed and up and running

 

Thanks

RC

0 Kudos
5 Replies
Highlighted
Xilinx Employee
Xilinx Employee
18,653 Views
Registered: ‎10-06-2016

Hi @optivareddy

 

a) Once you synced the repo you should have there a file called setupsdk. So the wikipage is corrected you should use "source setupsdk"

 

b) Did you check if those paths are correct and are pointing to your SDK installation paths? Check the environmental variables listed in the wikipage and check if you set up them correctly before running the build system.


Ibai
Don’t forget to reply, kudo, and accept as solution.
0 Kudos
Highlighted
Adventurer
Adventurer
18,641 Views
Registered: ‎11-27-2010

Hi,

    I don't see the folder [setupsdk] at all

 

root@dabba:~/yucto#
root@dabba:~/yucto#
root@dabba:~/yucto# pwd
/home/dabba/yucto
root@dabba:~/yucto#
root@dabba:~/yucto#
root@dabba:~/yucto# ls
pkgsetup  README.md  setup  sources
root@dabba:~/yucto#
root@dabba:~/yucto#

 

meanwhile, i am running the repo commands for version 2016.2

 

Thanks

RC Reddy

0 Kudos
Highlighted
Adventurer
Adventurer
18,597 Views
Registered: ‎11-27-2010

stuck at this now,

                       any help i can get

 

root@root:~/yoctoxil/build# bitbake petlinux-minimal
ERROR: OE-core's config sanity checker detected a potential misconfiguration.
Either fix the cause of this error or at your own risk disable the checker (see sanity.conf).
Following is the list of potential problems / advisories:

Do not use Bitbake as root.

Summary: There was 1 ERROR message shown, returning a non-zero exit code.
root@root:~/yoctoxil/build#

0 Kudos
Highlighted
Adventurer
Adventurer
18,582 Views
Registered: ‎11-27-2010

$ touch conf/sanity.conf

root@root:~/yoctoxil/build#
root@root:~/yoctoxil/build#
root@root:~/yoctoxil/build# MACHINE=zcu102-zynqmp bitbake petalinux-minimal
Parsing recipes: 25% |############################

 

finally this helped

 

solution at this link

 

https://github.com/gmacario/easy-build/tree/master/build-yocto

Highlighted
Newbie
Newbie
673 Views
Registered: ‎06-17-2020

Added command: touch conf/sanity.conf

0 Kudos