cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Observer
Observer
2,566 Views
Registered: ‎05-03-2017

ZCU102-ES2 BSP on Petalinux 2017.1

Jump to solution

Hello,

I have recently switched to Petalinux 2017.1 environment, but still have a ZCU102-ES2 development board.

The ZCU102 BSP image for 2017.1 fails to load the FPGA bitstream because of a version mismatch. The older ZCU102-ES2 BSP from 2016.4 fails to build on 2017.1

Will there be a 2017.1 BSP for ES2 silicon or is there a way to rebuild the default FPGA bitstream for the ES2 silicon?

 

Thanks

Thomas

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Participant
Participant
4,377 Views
Registered: ‎11-10-2016
2 Replies
Highlighted
Adventurer
Adventurer
2,495 Views
Registered: ‎09-05-2007

to flash bitstream to zcu102-ES2 with vivado2017.1 disable version check with :

set_param xicom.use_bitstream_version_check false

 

with petalinux2017.1, you can boot from SD (create BOOT.bin and image.ub) 

(jtag boot hangs on bitstream check, I do not know if it is possible to disable this check)

 

raph

0 Kudos
Highlighted
Participant
Participant
4,378 Views
Registered: ‎11-10-2016