We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

Showing results for 
Search instead for 
Did you mean: 
Visitor almartin
Registered: ‎10-06-2017

ZCU102 GPIO access through sysfs


I'm currently using the UltraScale+ MPSoC ZCU102 Evaluation Kit with re-built images from ZCU102-ZU9-ES2 Rev 1.0 BSP using Petalinux.


I would like to toggle GPIO (MIO) through sysfs in order to evaluate temporal performance of one of my application.


I run through the Linux GPIO driver tutorial. Kernel configuration option driver and .dtb are similar to the one provided in the tutorial.
Indeed, I get access to the "gpiochips338":
- label = zynqmp_gpio
- ngpio = 174 (26*3 = 78 mio + 32*3 = 96 emio)


In order to find if any of the MIO fit my purpose, i run through the [UG1182] "ZCU102 Evaluation Board User Guide" table 3-5 (p. 32). Sadly, none of them seem to be of exploitable outputs in current settings.


Question :
1) How is define the MIO interface settings in the boot process ?
2) How can I change these settings in order to enable GPIO through MIO or EMIO ?


PS : I'm a newbie in embedded development and eager to learn so do not hesitate to give details !

0 Kudos
1 Reply
Registered: ‎09-12-2007

Re: ZCU102 GPIO access through sysfs

I added a doc that I created a loooong time ago. However, your use case is here

0 Kudos