UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer yuhezhouping
Observer
1,095 Views
Registered: ‎07-10-2018

ZCU102 SD card boot error:** Bad device mmc 0 ** no mmc device at slot 0

Jump to solution

Problem:

When I use a xilinx official BSP to boot the UltraScale ZCU102 with a SD card,the error blow happened:

** Bad device mmc 0 **
no mmc device at slot 0

 

Board version:

ZYNQ UltraSCALE+     HW-Z1-ZCU102   REVISION 1.1

 

My step:

1.Download xilinx-zcu102-zu9-es2-rev1.0-v2018.2-final.bsp from https://www.xilinx.com/support/download/index.html/content/xilinx/en/downloadNav/embedded-design-tools.html

2.Use petalinux to create a bsp project

petalinux-create -t project -s <path-to-bsp>

3.Copy the two files blow  from bsp project xilinx-zcu102-zu9-es2-rev1.0-2018.2/pre-built/linux/images to SD card:

        BOOT.BIN

        image.ub

4.Plug the SD card into the board and power on the board

5.Boot messages:

Xilinx Zynq MP First Stage Boot Loader
Release 2018.2 Jun 15 2018 - 04:18:03
NOTICE: ATF running on XCZU9EG/silicon v4/RTL5.1 at 0xfffea000
NOTICE: BL31: Secure code at 0x0
NOTICE: BL31: Non secure code at 0x10080000
NOTICE: BL31: v1.4(release):xilinx-v2018.1-4-g93a69a5a
NOTICE: BL31: Built : 10:24:06, Jun 15 2018
PMUFW: v1.0


U-Boot 2018.01 (Jun 15 2018 - 04:10:27 -0600) Xilinx ZynqMP ZCU102 rev1.0

I2C: ready
DRAM: 4 GiB
EL Level: EL2
Chip ID: zu9eg
MMC: sdhci_send_command: MMC: 0 busy timeout increasing to: 200 ms.
sdhci_send_command: MMC: 0 busy timeout increasing to: 400 ms.
sdhci_send_command: MMC: 0 busy timeout increasing to: 800 ms.
sdhci_send_command: MMC: 0 busy timeout increasing to: 1600 ms.
sdhci_send_command: MMC: 0 busy timeout increasing to: 3200 ms.
sdhci_send_command: MMC: 0 busy timeout.
sdhci_send_command: MMC: 0 busy timeout.
mmc_init: -70, time 7889
sdhci@ff170000 - probe failed: -70
sdhci_send_command: MMC: 0 busy timeout.
sdhci_send_command: MMC: 0 busy timeout.
mmc_init: -70, time 7413

SF: Detected n25q512a with page size 512 Bytes, erase size 128 KiB, total 128 MiB
*** Warning - bad CRC, using default environment

In: serial@ff000000
Out: serial@ff000000
Err: serial@ff000000
Model: ZynqMP ZCU102 Rev1.0
Board: Xilinx ZynqMP
Bootmode: LVL_SHFT_SD_MODE1
Net: ZYNQ GEM: ff0e0000, phyaddr c, interface rgmii-id

Warning: ethernet@ff0e0000 MAC addresses don't match:
Address in ROM is 00:0a:35:04:a4:c9
Address in environment is 00:0a:35:00:22:01
eth0: ethernet@ff0e0000
U-BOOT for xilinx-zcu102-zu9-es2-rev1_0-2018.2

ethernet@ff0e0000 Waiting for PHY auto negotiation to complete......................................... TIMEOUT !
Hit any key to stop autoboot: 0
sdhci_send_command: MMC: 0 busy timeout.
sdhci_send_command: MMC: 0 busy timeout.
mmc_init: -70, time 7413
** Bad device mmc 0 **
no mmc device at slot 0
ZynqMP>

 

Is any body know how to solve the problem?

Thank you!

0 Kudos
1 Solution

Accepted Solutions
Explorer
Explorer
1,092 Views
Registered: ‎03-17-2011

Re: ZCU102 SD card boot error:** Bad device mmc 0 ** no mmc device at slot 0

Jump to solution

Hello @yuhezhouping

 

Have you tried another SD card?

 

Sebastien

--Sebastien
0 Kudos
5 Replies
Explorer
Explorer
1,093 Views
Registered: ‎03-17-2011

Re: ZCU102 SD card boot error:** Bad device mmc 0 ** no mmc device at slot 0

Jump to solution

Hello @yuhezhouping

 

Have you tried another SD card?

 

Sebastien

--Sebastien
0 Kudos
Observer yuhezhouping
Observer
1,044 Views
Registered: ‎07-10-2018

Re: ZCU102 SD card boot error:** Bad device mmc 0 ** no mmc device at slot 0

Jump to solution

 

 

0 Kudos
Observer come0088
Observer
837 Views
Registered: ‎01-03-2018

Re: ZCU102 SD card boot error:** Bad device mmc 0 ** no mmc device at slot 0

Jump to solution

Hi,

 I have encountered this problem before, but my SD card is good (it can be used normally on other machines), and it can be used after changing to a different model SD card

I think it may be that some models of SD card ZCU102 are not supported, such as different rates and class.

 

0 Kudos
Moderator
Moderator
835 Views
Registered: ‎09-12-2007

Re: ZCU102 SD card boot error:** Bad device mmc 0 ** no mmc device at slot 0

Jump to solution
Could be SD card, could be HW, could be device tree. Please share HDF, and dts so they can be reviewed
0 Kudos
Highlighted
Observer come0088
Observer
829 Views
Registered: ‎01-03-2018

Re: ZCU102 SD card boot error:** Bad device mmc 0 ** no mmc device at slot 0

Jump to solution

I used the SD card downloaded from the official website and did not make any changes

0 Kudos