UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer calex
Observer
1,029 Views
Registered: ‎08-09-2012

ZCU102 V1.0 + petalinux 2017.4 : ttyPS1 uart doesn't work

Jump to solution

hi all,

 

i'm doing some tests with jailhouse and i need 2 active UARTs on a ZCU102, ttyPS0 and ttyPS1.

I use the xilinx-zcu102-v2017.4-final.bsp to create a petalinux distro. Everything is fine except ttyPS1.

During the boot, the ttyPS0 is enabled but not the ttyPS1 (see attached boot log file) : 

 

[ 1.470270] Btrfs loaded, crc32c=crc32c-generic
[ 1.475320] ff000000.serial: ttyPS0 at MMIO 0xff000000 (irq = 46, base_baud = 6249375) is a xuartps
[ 1.517457] mmc0: new high speed SDXC card at address 0007
[ 1.517702] mmcblk0: mmc0:0007 SD64G 59.0 GiB
[ 1.518922] mmcblk0: p1 p2
[ 3.116845] console [ttyPS0] enabled
[ 3.120927] ff010000.serial: ttyPS1 at MMIO 0xff010000 (irq = 47, base_baud = 6249375) is a xuartps
[ 3.134560] PLL: shutdown
[ 3.137215] [drm] load() is defered & will be called again
[ 3.143189] xilinx-psgtr fd400000.zynqmp_phy: Lane:1 type:8 protocol:4 pll_locked:yes
[ 3.151161] xilinx-drm-dp fd4a0000.dp: device found, version 4.010

 

when i look at the device files, i see : 

 

root@saumon:~# ls -la /dev/ttyPS*
crw------- 1 root tty 253, 0 Jun 20 17:48 /dev/ttyPS0
crw-rw---- 1 root dialout 253, 1 Jun 20 17:47 /dev/ttyPS1
root@saumon:~#

 

i have tried to activate  /dev/ttyPS1 with stty, without any success.

It seems (from jailhouse developpers) that both UARTs used to work

before 2016.4.

 

I use a production ZCU102 V1.0

 

regards

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Observer calex
Observer
1,114 Views
Registered: ‎08-09-2012

Re: ZCU102 V1.0 + petalinux 2017.4 : ttyPS1 uart doesn't work

Jump to solution

hi Kranthi,

 

i can make it work.

the uart1 (/dev/ttyPS1) is connected on /dev/ttyUSB1 on my PC,

default speed = 9600.

 

i can change the conf using

  stty -F /dev/ttyPS1 115200 cs8 -cstopb -parenb
  stty < /dev/ttyPS1

 

and verify the result with

  echo hello  > /dev/ttyPS1

 

thank you for all

 

regards

0 Kudos
2 Replies
Xilinx Employee
Xilinx Employee
991 Views
Registered: ‎06-27-2017

Re: ZCU102 V1.0 + petalinux 2017.4 : ttyPS1 uart doesn't work

Jump to solution

Hi @calex,

 

In recent petalinux releases, Uart1 is disabled by default. You need to enable it manually to use it.

1. Add below node in <petalinux project>/project-spec/meta-user/recipes-bsp/device-tree/files/system-user.dtsi

     &uart1 {

                      status = "okay";

                };

2. Then build the petalinux using petalinux-build command

 

Regards,

Kranthi

--------------------------

Don't forget to reply, kudo, and accept as solution.

Best Regards
Kranthi
--------------------------
Don't forget to reply, kudo, and accept as solution.
0 Kudos
Highlighted
Observer calex
Observer
1,115 Views
Registered: ‎08-09-2012

Re: ZCU102 V1.0 + petalinux 2017.4 : ttyPS1 uart doesn't work

Jump to solution

hi Kranthi,

 

i can make it work.

the uart1 (/dev/ttyPS1) is connected on /dev/ttyUSB1 on my PC,

default speed = 9600.

 

i can change the conf using

  stty -F /dev/ttyPS1 115200 cs8 -cstopb -parenb
  stty < /dev/ttyPS1

 

and verify the result with

  echo hello  > /dev/ttyPS1

 

thank you for all

 

regards

0 Kudos