cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Contributor
Contributor
407 Views
Registered: ‎07-17-2019

ZCU102 bootable image issue

I am creating a bootable image following https://xilinx-wiki.atlassian.net/wiki/spaces/A/pages/18841937/Zynq+UltraScale+MPSoC+Ubuntu+part+2+-+Building+and+Running+the+Ubuntu+Desktop+From+Sources

Bord revision 1.1

SW6 is set to: [4:1] -> off, off, off, on.

monitor is connect througt displayport.

16GB SD card was formated following instruction first: https://xilinx-wiki.atlassian.net/wiki/spaces/A/pages/18842385/How+to+format+SD+card+for+SD+boot

Then extracted ZCU102_UbuntuDesktop_2018_3.img to sd card.

sdboot1.png

Then mark sdc1 as bootable and change it's file system type to Linux.

sdBoot.png

 

But the Init_B led stay red and monitor does not have signal after power turned on.  What could be the problem? Thanks!

0 Kudos
4 Replies
Visitor
Visitor
208 Views
Registered: ‎07-30-2019

Re: ZCU102 bootable image issue

I have the same issue using the prebuilt image. INIT_B stays RED and no video from DisplayPort.

I also tried the prebuilt image from

https://xilinx-wiki.atlassian.net/wiki/spaces/A/pages/18842112/Zynq+UltraScale+MPSoC+Ubuntu+part+1+-+Running+the+Pre-Built+Ubuntu+Image+and+Power+Advantage+Tool

INIT_B turns GREEN. But no video from DisplayPort.

I use ZCU102 Rev 1.1, too.

Have you found a solution? Thanks,

0 Kudos
Highlighted
Mentor
Mentor
192 Views
Registered: ‎06-16-2013

Re: ZCU102 bootable image issue

Hi @lzhao  and @jiez 

 

Change formatted type from linux (ext3) to fat32.

In this case, boot loader requires fat32 partition at 1st partition.

 

Best regards,

0 Kudos
Highlighted
Contributor
Contributor
139 Views
Registered: ‎07-17-2019

Re: ZCU102 bootable image issue

Hi JieZ,

 

In my case it's combination of several problems. I did some research, and following is the steps that solved my problem. But before you start making adjustment, I want to let you know that after I made all these adjustment, everything seems working fine expect that the Init_B led still stay red all the time. I've also tried two other bootable images from Xilinx, none of those two bootable image has this problem.

Follwing are the issues you may need to considering. Hope thsi helps.

1. Making bootable image:
https://xilinx-wiki.atlassian.net/wiki/spaces/A/pages/18841937/Zynq+UltraScale+MPSoC+Ubuntu+part+2+-+Building+and+Running+the+Ubuntu+Desktop+From+Sources

2. Format SD card procedure:
https://xilinx-wiki.atlassian.net/wiki/spaces/A/pages/18842385/How+to+format+SD+card+for+SD+boot
https://askubuntu.com/questions/1064278/how-to-create-win95-fat32-lba-partition-type-on-32-gb-usb
Note: creating partitions on SD card is not necessary. Actually, if the partitions was not created properly, it could casue problems when extracting bootable image to SD card.
I used the balenaEtcher to create the image.

3. USB to UART drivers

(My first display is not supported by this linux system, so make sure that your display is functional and supported by this version of linux.)  You can use Putty to check the info during the boot process.

https://xilinx-wiki.atlassian.net/wiki/spaces/A/pages/18842446/Setup+a+Serial+Console
I downloaded the version for windows10.

 

4. Jumper setting for keyboard and mouse:
https://forums.xilinx.com/t5/Embedded-Linux/Keyboard-Issue-about-Ubuntu-Desktop-on-ZCU102-Rev-1/td-p/774258
https://www.xilinx.com/support/answers/69164.html

 

5. configuring network on ubuntu
https://www.swiftstack.com/docs/install/configure_networking.html

0 Kudos
Highlighted
Visitor
Visitor
111 Views
Registered: ‎07-30-2019

Re: ZCU102 bootable image issue

Hi lzhao,

 

Thanks. Currently I'm using Raspberry Pi since for now what I need is the Cortex-A53. Raspberry Pi is much easier to get the latest Linux distribution running on it. When I have to switch to ZCU102, I will try your instructions. Thanks again.

 

Jie

0 Kudos