UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
418 Views
Registered: ‎10-24-2019

ZCU104 DOES NOT BOOT

Hello everyone,

I am trying to boot my ZCU104 board and I followed the following steps to build my project:

1- I created hardware design for zcu106 from .tcl file. I followed the instructions in this URL  (https://xilinx-wiki.atlassian.net/wiki/spaces/A/pages/115933296/Zynq+UltraScale+MPSoC+VCU+TRD+2019.1+-+Run+and+Build+Flow)

2- I adjusted the design according to zcu104.

3- I exported hdf file.

4- I created BOOT.bin and image.ub files with Petalinux:   

petalinux-create --type project --template zynqMP -s <PATH_TO_BSP> --name proj1
petalinux-config --get-hw-description=<PATH-TO-HDF/DSA-DIRECTORY>
petalinux-build -c bootloader -x distclean
petalinux-build
petalinux-package --boot --format BIN --fsbl zynqmp_fsbl.elf --u-boot u-boot.elf --pmufw pmufw.elf --fpga system.bit --force

5- Finally, I coppied BOOT.bin and image.ub files to SD card.

But when I set the board to boot mode and connect to my PC nothing comes up in the console. Can you help me.

Best regards,

 

0 Kudos
10 Replies
Moderator
Moderator
388 Views
Registered: ‎09-12-2007

Re: ZCU104 DOES NOT BOOT

petalinux-create --type project -s <PATH_TO_BSP>

Can you use the command above? There are two ways to create the project; using the template, or the bsp.

You seem to be using both.

 

Can you try the images in the prebuilt folder to test your boot?

0 Kudos
380 Views
Registered: ‎10-24-2019

Re: ZCU104 DOES NOT BOOT

Hi Stephenm,

Thank you for quick reply. I tried the images in the prebuilt folder to test my boot and there isn't any problem.

Actually I tried to create default project is created by using: petalinux-create --type project --template zynqMP -s <PATH_TO_BSP> --name proj1  ,
and I think that my project modifies the above initial project by using petalinux-config --get-hw-description <path_hdf>. Did I think right? I am new in Xilinx :)

Secondly, Does it any effect if I used both? 

Best regards,

 

0 Kudos
Moderator
Moderator
375 Views
Registered: ‎09-12-2007

Re: ZCU104 DOES NOT BOOT

If you are using the zcu104 board then you should use

petalinux-create -t project -s <path to zcu104 bsp>.bsp

petalinux-config --get-hw-description=<path to hdf>

 

If you have a custom board with a zynq ultrascael device on it, then you would do

petalinux-create -t project --template zynqMP -n plnx_project

petalinux-config --get-hw-description=<path to hdf>

 

Using the BSP, will set board specific configs such as the device-tree, and will update the fsbl to

do board init for your zcu104 bord. These would need to be handled manually if using the template.

 

0 Kudos
352 Views
Registered: ‎10-24-2019

Re: ZCU104 DOES NOT BOOT

Hi,

I have created with petalinux-create -t project -s <path to zcu104 bsp>.bsp. But it still doesn't work.

0 Kudos
Moderator
Moderator
337 Views
Registered: ‎09-12-2007

Re: ZCU104 DOES NOT BOOT

So, if you do petalinux-create -t project -s <path to bsp>.bsp, then the prebuilt files delivered here work.

 

However, if you do a

  • petalinux-config --get-hw-description=<path to hdf>
  • petalinux-build
  • cd images/linux
  • petalinux -package --boot --fpga system.bit --u-boot

 

Then this doesnt work? What doesnt work? Can you share the boot log?

0 Kudos
332 Views
Registered: ‎10-24-2019

Re: ZCU104 DOES NOT BOOT

Anything isn't seen in serial terminal.

0 Kudos
Xilinx Employee
Xilinx Employee
222 Views
Registered: ‎09-17-2019

Re: ZCU104 DOES NOT BOOT

Hi aysenurakinci805@gmail.com,

Can you please once try to boot with prebuilt images.

and also share your HDF so we can verify it at our end.

 

0 Kudos
178 Views
Registered: ‎10-24-2019

Re: ZCU104 DOES NOT BOOT

Hi Smahalle,

I tried to boot with prebuilt images, and there is not any problem. 

I have attached HDF file,

Best regards,

0 Kudos
Moderator
Moderator
133 Views
Registered: ‎09-12-2007

Re: ZCU104 DOES NOT BOOT

Just to clarify your flow:

petalinux-create -t project -s <path to bsp>.bsp

cd <plnx proj>

petalinux-config --get-hw-description=<path to hdf>

petalinux-build -x mrproper

petalinux-build

cd images/linux

petalinux-package --boot --fpga system.bit --u-boot

 

 

0 Kudos
25 Views
Registered: ‎10-24-2019

Re: ZCU104 DOES NOT BOOT

Yes, I followed this steps.

0 Kudos